Use arrowscrollbox buttons to notify of unread messages in tab overflow mode.

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
5 years ago
26 days ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
*** Original post on bio 450 by patrickjdempsey <pjdkrunkt AT lycos.com> at 2010-07-17 01:13:00 UTC ***

When you have many conversations going on in one window, this triggers tab overflow mode.  The you have an unread message past the overflow it is difficult to find. The only notification we get is that the taskbar item and the title frame flashes a few times to indicate an unread message.  If you happen to miss this then you will have no idea of a new message.  My suggestion is to animate the backgrounds of the arrowscrollbox buttons to indicate an unread message.  You could use an animated PNG graphic slowly flashing transparent-to-red-to-transparent.  This could flash perpetually until the message is read.  Ideally, only the arrowscrollbox in the direction of the unread message would flash, but I do not know if that is possible to detect.
*** Original post on bio 450 at 2010-07-17 07:57:55 UTC ***

There's already something that is highlighted (I don't remember if it's the arrow or the "all tabs" button) when a new tab is added and hidden because of the overflow. I think this highlight should happen each time there's an unread personal message, not only when there's a new tab.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: x86 → All
(Reporter)

Comment 2

5 years ago
*** Original post on bio 450 by patrickjdempsey <pjdkrunkt AT lycos.com> at 2010-07-17 18:41:55 UTC ***

Yes, the all tabs button highlights briefly if a new conversation starts in overflow.  Again, it's only very briefly, so if you aren't looking right at it you might miss it.  There does seem to be some method there for knowing that the tab is obscured by the overflow, so this would would well everytime there is an unread tab in overflow.
On the behalf of Florian:
Closing bugs related to the Instantbird UI as WONTFIX, as the development of the standalone chat client Instantbird has stopped. Instantbird users are encouraged to migrate to Thunderbird. The user interface of instant messaging in Thunderbird will feel familiar, as the Thunderbird IM support started as a fork of Instantbird.
Status: NEW → RESOLVED
Last Resolved: 26 days ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.