Unable to send messages (Latest nightly seems broken)

RESOLVED WORKSFORME

Status

Instantbird
Conversation
--
critical
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Instantbot, Unassigned)

Tracking

trunk
x86
Windows 7

Details

(Reporter)

Description

4 years ago
*** Original post on bio 569 by deOmega <jahkae AT gmail.com> at 2010-10-30 15:17:00 UTC ***

After the update to version 0.3a1pre (20101030041707), I am unable to send  messages or even start another conversation in  currently opened tab.
*** Original post on bio 569 at 2010-10-30 15:34:35 UTC ***

Even said something like this about yesterdays nightly build, maybe todays is affected in the same manner. Are there any errors on the error console?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

4 years ago
*** Original post on bio 569 by deOmega <jahkae AT gmail.com> at 2010-10-30 21:15:54 UTC ***

I find with  many of these Mozilla programs, there are always errors or something in the error console... so i cleared it and tried to start a conversation window, and these are what  came up:

Error: uncaught exception: [Exception... "Component does not have requested interface arg 0 [nsIContainerBoxObject.docShell]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: chrome://global/content/bindings/editor.xml :: get_docShell :: line 0"  data: no]

Error: uncaught exception: [Exception... "Component does not have requested interface arg 0 [nsIContainerBoxObject.docShell]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: chrome://instantbird/content/convbrowser.xml :: get_docShell :: line 0"  data: no]

Error: uncaught exception: [Exception... "Component does not have requested interface arg 0 [nsIContainerBoxObject.docShell]"  nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: chrome://instantbird/content/convbrowser.xml :: get_docShell :: line 0"  data: no]

Error: tabbrowser.selectedConversation is undefined
Source File: chrome://replytonick/content/replytonick.js
Line: 58

Error: purple_upnp_set_port_mapping(): Failed HTTP_OK
HTTP/1.1 500 Internal Server Error
DATE: Sat, 30 Oct 2010 14:12:44 GMT
Connection: Keep-Alive
Server: LINUX/2.4 UPnP/1.0 BRCM400/1.0
Content-Length: 466
Content-Type: text/xml; charset="utf-8"
EXT:

<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/" s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/">
 <s:Body>
  <s:Fault>
   <faultcode>s:Client</faultcode>
   <faultstring>UPnPError</faultstring>
   <detail>
    <UPnPError xmlns="urn:schemas-upnp-org:control-1-0">
     <errorCode>714</errorCode>
     <errorDescription>NoSuchEntryInArray</errorDescription>
    </UPnPError>
   </detail>
  </s:Fault>
 </s:Body>
</s:Envelope>


Source File: http://hg.instantbird.org/instantbird/raw-file/2d33324cdb9d/purple/libpurple/upnp.c
Line: 861
Source Code:
upnp: done_port_mapping_cb

And this when I try to hit enter to send a message:

Error: MessageFormat is not defined
Source File: chrome://instantbird/content/conversation.xml
Line: 285

Comment 3

4 years ago
*** Original post on bio 569 at 2010-10-31 07:25:18 UTC ***

Yes I had this same error on 2010102904xxxx. The strange part is that updating to the next version (20101030041707), the same one that fails for deOmega, corrected the problem for me. Maybe a problem with symbol registration or something like this ?

I'm not marking any more nightlies as ignore since the problem looks a little more complicated than this. I suspect an update issue (partial gets wrong, next day's partial fails and complete gets it right).

Comment 4

4 years ago
*** Original post on bio 569 at 2010-10-31 07:29:08 UTC ***

Might even be the same bug than #551 but on the "partial update succeeds" side (the rare scenario for which we don't have too much infos as of now).
(Reporter)

Comment 5

4 years ago
*** Original post on bio 569 by deOmega <jahkae AT gmail.com> at 2010-10-31 16:13:40 UTC ***

Everything is now working fine after the Halloween update...  version 0.3a1pre (20101031041711)

(I like the icon by the way)
*** Original post on bio 569 at 2011-01-17 13:55:35 UTC ***

Is this bug still valid? It sounds like the problem went away after Halloween.
(Reporter)

Comment 7

4 years ago
*** Original post on bio 569 by deOmega <jahkae AT gmail.com> at 2011-01-17 16:28:38 UTC ***

Bug no longer valid.  Everything is working fine.
*** Original post on bio 569 at 2011-01-17 18:31:57 UTC ***

Problem is gone (see comment 17).
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.