Crash when attempting to view any certificate on MacOSX

VERIFIED DUPLICATE of bug 96160

Status

P1
critical
VERIFIED DUPLICATE of bug 96160
17 years ago
2 years ago

People

(Reporter: ckritzer, Assigned: ddrinan0264)

Tracking

({crash})

1.0 Branch
psm2.1
PowerPC
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Overview:  While trying to verify another bug, I was attempting to view a
certificate by clicking on the 'View' button, and the app crashed.

Steps to reproduce:
1) Launch MacOS_X 2001-08-14-05-trunk (commercial)
2) Follow the path Edit:Preferences:Privacy and Security:Certificates and click
on the [Manage Certificates] button
3) In the Certificate Manager window, select any available cert and click the
[View] button

Actual Results: App crashes

Expected Results: View the cert

Platforms tested:
 - MacOS91 2001-08-14-04-trunk (commercial)
 - MacOS_X 2001-08-14-05-trunk (commercial)
 - LinRH62 2001-08-14-07-trunk (commercial)
 - Win09SE 2001-08-14-06-trunk (commercial)
Additional Info:  This crash only happens on MacOS_X - I can view the certs on
other platforms just fine.
(Reporter)

Comment 1

17 years ago
Updated summary from:

Crash when attempting to view any certificate

To:

Crash when attempting to view any certificate on MacOSX
Summary: Crash when attempting to view any certificate → Crash when attempting to view any certificate on MacOSX

Comment 2

17 years ago
->javi
P1
t->2.1
nsenterprise
Assignee: ssaux → javi
Keywords: crash, nsenterprise
Priority: -- → P1
Target Milestone: --- → 2.1

Comment 3

17 years ago
adding sdagley to cc list.

Comment 4

17 years ago
bestowing nsenterprise+ keyword
Keywords: nsenterprise → nsenterprise+

Comment 5

17 years ago
Did we get an update on this before Javi left on sabbatical?

Comment 6

17 years ago
Steve,
Here's what Javi had to say on 8/20 before he left:


I've got the Mac development environments going and have come to the conclusion
that fixing a Mac OS X bug (that doesn't also occur in Mac
OS 9) is almost impossible due to the fact that you can not run the builds under
a debugger.  Gathering actual run-time info is impossible except for
true Mac experts.

Where does this leave us?  Steve Dagley has offered to help out with Mac
specific PSM issues during my sabbatical and he also knows there are
PSM bugs that are Mac OS X specific (he's cc'ed on the bugs).  The team will
have to rely on his help to resolve any Mac OS X issues that arise
during my sabbatical  (Unless someone else wants to figure out debugging on Mac
OS X.)


In the short term, this means I will not be able to close my P1 bugs that are
Mac OS X specific (Bugs 89281 and 95404) before I leave on
sabbatical (barring some miraculous break through by MacDev allowing developers
to properly debug on Mac OS X by say tomorrow).

Comment 7

17 years ago
setting to future.
Target Milestone: 2.1 → Future

Updated

17 years ago
Keywords: nsenterprise+

Comment 8

17 years ago
ssaux@netscape.com:

Do you have another engineer who can fix this bug? 

Comment 9

17 years ago
Stephane,  Is there someone in the security group that can look at this?  I can 
help someone try and debug but I have other fish to fry so to speak and can't 
work on this full time right now.

Comment 10

17 years ago
Javi is the best resource I have for this bug and he found it "nearly
impossible" to fix.  It's unlikely that if I assign somebody else to work on it,
the bug will get fixed during the 0.9.4 branch lifetime.

Bring it up to a PDT meeting.

Comment 11

17 years ago
Is there at least a QA resource that can be assigned to get more info since 
ckritzer is no longer a Netscape employee?

Comment 12

17 years ago
Let me get back to you (tomorrow).
cc ddrinan.

Comment 13

17 years ago
--> Lord for reassignment.
Assignee: javi → lord

Comment 14

17 years ago
We do not understand how to debug Mac OSX.  Javier tried and failed.  I asked
David Drinan give a call to sdagley to see how they can work together to get
this issue resolved. 

Comment 15

17 years ago
back on the 2.1 radar.
Target Milestone: Future → 2.1

Comment 16

17 years ago
ddrinan
Assignee: lord → ddrinan

Comment 17

17 years ago
Marking fixed on Trunk, still crashes on 9/19 branch. Adding vbranch keyword.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Keywords: vbranch
QA Contact: ckritzer → junruh
Resolution: --- → FIXED

Comment 18

17 years ago
Is this still happening on the branch?  Is this a must fix for the 0.9.4 branch?

Comment 19

17 years ago
The fix is not on the branch. Today's build crashes. Aren't crashers "must fix"?

Comment 20

17 years ago
If it's not on the branch then it probably shouldn't be marked fixed.

David Drinan's understanding is that sdagley would investigate why it's not
happening on the trunk and try to identify and apply the fix that solved the
problem.

Reopening.  vbranch is not a good way to keep it on the radar.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 21

17 years ago
The thought was this bug is a dupe of <http://bugzilla.mozilla.org/
show_bug.cgi?id=96160> which is why I asked if the trunk worked.  Now that it has 
been verified that it does, this bug can be closed as a dupe.

Comment 22

17 years ago
dupe as per Steve's comments.

*** This bug has been marked as a duplicate of 96160 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 23

17 years ago
Verified dupe.
Status: RESOLVED → VERIFIED

Updated

14 years ago
Component: Security: UI → Security: UI
Product: PSM → Core

Updated

10 years ago
Version: psm2.1 → 1.0 Branch
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.