Placeholder icon shown inconsistently for private conversations on IRC

RESOLVED WONTFIX

Status

--
minor
RESOLVED WONTFIX
5 years ago
2 years ago

People

(Reporter: Mic, Unassigned, Mentored)

Tracking

Details

(Reporter)

Description

5 years ago
*** Original post on bio 1365 at 2012-04-06 20:55:00 UTC ***

There's a placeholder usericon shown on private conversations when the contact is added to the contact list and there's none, when the other isn't added.

We should be consistent here, one way or another.

Comment 1

5 years ago
*** Original post on bio 1365 at 2012-04-06 20:58:00 UTC ***

I would resolve this a duplicate of bug 954049 (bio 613), if clokep agrees.
*** Original post on bio 1365 at 2012-04-06 21:47:07 UTC ***

(In reply to comment #1)
> I would resolve this a duplicate of bug 954049 (bio 613), if clokep agrees.

No, this is a different issue than bug 954049 (bio 613).

This is probably not an IRC issue. It's probably due to having a conversation w/ someone without the buddy field set.

Comment 3

5 years ago
*** Original post on bio 1365 at 2012-04-06 22:01:13 UTC ***

(In reply to comment #2)
> This is probably not an IRC issue. It's probably due to having a conversation
> w/ someone without the buddy field set.

While this is true, does it actually happen for any other protocol? What I meant was that for IRC it will go away if bug 954049 (bio 613) is fixed by adding temporary buddies for conversation partners.
*** Original post on bio 1365 at 2012-05-08 11:58:04 UTC ***

(In reply to comment #3)
> (In reply to comment #2)
> > This is probably not an IRC issue. It's probably due to having a conversation
> > w/ someone without the buddy field set.
> 
> While this is true, does it actually happen for any other protocol? What I
> meant was that for IRC it will go away if bug 954049 (bio 613) is fixed by adding temporary
> buddies for conversation partners.

Even if it will go away for IRC, it could still be an underlying issue that should be "fixed" (or WONTFIXed).

The issue is at http://lxr.instantbird.org/instantbird/source/instantbird/content/conversation.xml#1364, this is only set if there's a buddy.

We should probably (in the implementation somewhere) return the "no icon set" icon if there isn't a buddy icon set.
Severity: normal → minor
Component: IRC → General
OS: Windows 7 → All
Hardware: x86 → All
*** Original post on bio 1365 at 2012-05-09 10:35:32 UTC ***

So if I remember correctly, what I intended to do was showing the placeholder to mean "there could be an icon, but the contact hasn't set it". When the buddy isn't in the contact list, there's no way we could have an icon, so there's no placeholder.

So the problem we may want to fix is that the placeholder makes no sense for IRC buddies, even when they are in the contact list.

What makes things complicated though is that if the buddy is grouped with other buddies in a contact, the other buddies may be on other protocols that support icons...

Updated

4 years ago
Mentor: aleth
Component: General → Conversation
Product: Chat Core → Instantbird
Whiteboard: [good first bug]
Hi,
Im new to InstantBird, and i would like to work on this,
Would you help me on getting started
I have already build.
Thanks :D
I don't see user value in fixing this, we likely have better things to spend time on.

Pavan, I see you have already found your way to our IRC channel, so hopefully we can find a bug you'll be interested in :-).
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
Whiteboard: [good first bug]
You need to log in before you can comment on or make changes to this bug.