IRC messages that need a : for the last parameter broken

RESOLVED FIXED in 1.2

Status

--
major
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: clokep, Assigned: clokep)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
*** Original post on bio 1442 at 2012-05-18 10:42:00 UTC ***

*** Due to BzAPI limitations, the initial description is in comment 1 ***
(Assignee)

Updated

5 years ago
Blocks: 954803
(Assignee)

Comment 1

5 years ago
Created attachment 8353237 [details] [diff] [review]
The fix

*** Original post on bio 1442 as attmnt 1484 at 2012-05-18 10:42:00 UTC ***

I made a change in bug 954803 (bio 1369) to only provide the : for the last parameter of IRC messages if necessary (by checking if there's a space). There's another case where it's necessary: if the first letter of the string is a colon.

This adds this case.
Attachment #8353237 - Flags: review?

Comment 2

5 years ago
Comment on attachment 8353237 [details] [diff] [review]
The fix

*** Original change on bio 1442 attmnt 1484 at 2012-05-18 10:49:06 UTC ***

Haven't tested this, but it looks good :)
Attachment #8353237 - Flags: review? → review+

Updated

5 years ago
Whiteboard: [checkin-needed]
(Assignee)

Comment 3

5 years ago
*** Original post on bio 1442 at 2012-05-19 13:17:18 UTC ***

Additionally, the space detection algorithm doesn't work (as filed in bug 954878 (bio 1444)). This is really all part of the same bug so I'm making this more general and duping it. I have a new patch that fixes both coming up shortly.
Summary: IRC messages starting with a : and no spaces lose the : → IRC messages that need a : for the last parameter broken
(Assignee)

Updated

5 years ago
Duplicate of this bug: 954878
(Assignee)

Comment 5

5 years ago
Created attachment 8353238 [details] [diff] [review]
Patch v2

*** Original post on bio 1442 as attmnt 1485 at 2012-05-19 14:55:00 UTC ***

This fixes both the case where you start with a : and if you have spaces in it. slice returns an array (of one element in this case), so we need to grab the only element in it first.
Attachment #8353238 - Flags: review?(bugzilla)
(Assignee)

Comment 6

5 years ago
Comment on attachment 8353237 [details] [diff] [review]
The fix

*** Original change on bio 1442 attmnt 1484 at 2012-05-19 14:55:14 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8353237 - Attachment is obsolete: true

Comment 7

5 years ago
Comment on attachment 8353238 [details] [diff] [review]
Patch v2

*** Original change on bio 1442 attmnt 1485 at 2012-05-19 15:02:26 UTC ***

This one should work better :)
Attachment #8353238 - Flags: review?(bugzilla) → review+
(Assignee)

Comment 8

5 years ago
*** Original post on bio 1442 at 2012-05-20 17:58:44 UTC ***

Checked in as http://hg.instantbird.org/instantbird/rev/ee30357e62a1
Severity: normal → blocker
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Whiteboard: [checkin-needed]
Target Milestone: --- → 1.2
(Assignee)

Updated

5 years ago
Severity: blocker → major
(Assignee)

Updated

5 years ago
Duplicate of this bug: 954879
You need to log in before you can comment on or make changes to this bug.