trying to print this page submits no job to print queue

VERIFIED WORKSFORME

Status

()

Core
Printing: Output
VERIFIED WORKSFORME
17 years ago
4 years ago

People

(Reporter: Robert Praetorius, Assigned: dcone (gone))

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

17 years ago
when I try to print this page, I don't see any confirmation (e.g.,
page count), any sign of printer activity or any entry in the
print queue.  When attempting to print it to a file (using a
printer name preconfigured to print to file), I don't even get
prompted for a file name.  Also, no error indication appears.

It print just fine with Netscape 4.78

I compared this with
http://bugzilla.mozilla.org/show_bug.cgi?id=89151
and decided the symptom set was distinctly different
(although if you decide differently, well, y'all know this
stuff better than I do).
(Assignee)

Comment 1

17 years ago
I think it is the same bug, seems to be a map quest problem.  I think what your 
seeing is that the print job is never started because the printing code never 
gets notified that the image was loaded, hence.. the print job never starts.
Marking as dupe of bug 89151. 

I think this dupe makes sense, as the page mentioned here appears to be one big
dynamically generated gif.

*** This bug has been marked as a duplicate of 89151 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Verified Duplicate
Status: RESOLVED → VERIFIED

Comment 4

17 years ago
should work now in builds after 10/1.
(Reporter)

Comment 5

17 years ago
(this is the original bug reporter writing)

just tried this with 0.9.5.  Still broken, but the symptoms are different.
Another image-didn't-print bug I reported WAS fixed, so I'm guessing that
marking this as a duplicate was, perhaps, premature.

Anyway, the new symptom is: instead of printing, one gets a little dialog
box titled Printer error containing the text failure and an OK button.

note that, annoyingly, one needs to register with MapBlast to see this
page.
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 6

17 years ago
Created attachment 53639 [details]
requester you get when you try to print this page

Comment 7

17 years ago
is this a DUP of bug 101289 ?
(Reporter)

Comment 8

17 years ago
> is this a DUP of bug 101289 ?

     I wouldn't go so far as to say it's unrelated, but I'd say the
relation is secondary.  If I read 101289 correctly, it's about error
handling.  On this one, Mozilla shouldn't be getting an error in the
first place.  As the original problem statement said, Netscape 4.78
prints this page just fine.
(Reporter)

Comment 9

17 years ago
fails slightly differently now  in 0.9.6 (the requester says "Printing
failed for some reason.".  Also, don't know whether this helps narrow
it down or not, but the page shows up fine in print preview (and still
fails to print if a print preview is done before printing is done).

Comment 10

17 years ago
cc: rods

Rod, this is the second time I'm seeing someone mention: "Printing
failed for some reason" in a bug report.

any ideas?

Comment 11

17 years ago
The URI seems to no longer work. To reproduce this problem, I went to
http://www.mapblast.com/. I wanted to create a map. Eventually I got to this URI. 

http://www.vicinity.com/a7eleven/geoprx.hm?AD2=312+whitehorse+pike&CITY=lindenwold&STATE=nj&ZIP=&AD4=USA

Using Build ID 2001120303, the map printed correctly. Importantly, bug 89151
recently was resolved, fixed, and verified. Considering the similarity between
these bugs, I am marking this bug as a dupe of bug 89151.

*** This bug has been marked as a duplicate of 89151 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 12

17 years ago
verified.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 13

17 years ago
Did you login in to Mapquest?  As 
http://bugzilla.mozilla.org/show_bug.cgi?id=95495#c5
notes, you need to register with Mapquest to see this page.

Attached .PNG shows that (b) the URI still works and
(1) printing is still broken (and, tertiarily that this is
not a duplicate of http://bugzilla.mozilla.org/show_bug.cgi?id=89151 ,
which I just retested and found to be fixed)


Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 14

17 years ago
Created attachment 60334 [details]
new error requester for printing error (with Mozilla 0.9.6 backdrop)
Andrew: Could you try this one again, taking into account comment #13? Also,
please always CC yourself on a bug when you make changes -- that way, you'll
know right away if the reporter replies or disagrees with your change :).

Comment 16

17 years ago
Does this bug reference mapblast.com or mapquest.com? The URL line indicates
this is a problem associated with mapblast.com. I am proceeding as if the bug
references mapblast.com and not mapquest.com.

This time, I registered with mapblast.com. I logged in. I got to the page in the
URL. I printed it out. No problem. In summary, worksforme Mozilla 0.9.6 Build
ID: 2001120403, Lexmark Optra Ep. 

Reporter, please delete your printer icon from the Control Panel, download a new
printer driver, install the new one, and try it again. If it still doesn't work,
try using the modern or classic skin. If it still doesn't work, try reinstalling
Mozilla. 

In any case, please tell us what happens.
(Reporter)

Comment 17

17 years ago
that should be MapBlast, not MapQuest.  My goof.

This happens just the same with all the printers I have defined
(HP LaserJet 5/5M PostScript, AdobePSHPLaserJet5/5MPostScript
and Generic/Text Only are the drivers.  Ports are DLC, TCP and
output to file).  The printers set up by default for output to
file don't even prompt for a filename (which seems to happen
before processing).

But, what the heck, I updated my AdobePS driver and rebooted
and reinstalled Mozilla 0.9.6 and set the theme back to Modern
and the color scheme back to windows default.  You can observe
the results in the attached .PNG.  Same error message, different
glitter.

I notice you're running a more recent baselevel than I am.
I'll see if the nightly does me any better than 0.9.6.
(Reporter)

Comment 18

17 years ago
Created attachment 60504 [details]
same error message in more conventional trim
(Reporter)

Comment 19

17 years ago
I just tried to reproduce this with 2001120509 and ended up
putting 4 crashes in the talkback queue just trying to get
logged in to MapBlast.  Maybe I'll retry this in 0.9.7.

Just to be clear about this (since those "is the computer
turned on?" questions have to be asked): this is the only
printing problem I've noticed with 0.9.6 (other ones I used
to have with Mozilla seem to have been fixed) and I'm not
noticing printing problems with any of the other applications
I use with any of the printers I use.

Comment 20

17 years ago
We don't know anything about the people who file bug reports, and so we have to
assume the lowest common denominator in terms of experience. This must make me
sound condescending at times, and I apologize for that.

Couple of suggestions. Mozilla may have horked itself during installation. You
might have to go in as Administrator on your NT box and delete all the Mozilla
files in your program files directory or directories, keeping your profiles, of
course. Then download a fresh 0.9.6 and a fresh nightly for your reinstalls. For
the printer driver, this might be that rare circumstance where an obscure bug in
an old driver shows up, where it doesn't show up in other apps, or even on other
web pages.

Finally, this problem could be limited to Win NT. I can only test it on 98.
(Reporter)

Comment 21

17 years ago
> This must make me sound condescending at times, and I apologize for that

     No apology needed.  I've had that job, too.  To talk to random users
is to sound condescending at times.  And even experienced users do stupid
things from time to time.  I know I have.  C'est la vie, c'est la guerre,
c'est la pomme de terre.  I didn't mean to sound grumpy.  I apologize for
that.

> delete all the Mozilla files in your program files directory or
> directories, keeping your profiles, of course.  Then download a fresh
> 0.9.6 and a fresh nightly for your reinstalls.

     Done.  Dies the same way (0.9.6 can't print the page, the nightly
talks to talkback when I tried to log in to MapBlast).

> For the printer driver, this might be that rare circumstance where
> an obscure bug in an old driver shows up, where it doesn't show up
> in other apps, or even on other web pages.

     Ayuh.  Different products exercise different code paths in other
products.  I'm with ya there.  But, as
http://bugzilla.mozilla.org/show_bug.cgi?id=95495#c17
notes, this is happening with 3 different old drivers and one new
printer driver (the fresh copy of AdobePS I just installed).  Low odds
in my book.

> Finally, this problem could be limited to Win NT. I can only test it
> on 98.

     Perhaps some white knight out there will give it a shot.

     Hey, this ain't exactly holding me up.  As noted in the first
response, I have my workaround.  I'm just trying to help y'all find a
broken spot in your code, or a broken interaction with 3rd party code
or whatever's going on.  I'm happy to apply more diagnostic measures.
I'll just tend to get whiny when somebody tries to close this one off
and I can still easily reproduce it.

Comment 22

17 years ago
Thank you. We do appreciate your help and patience. If we can fix this bug, it
makes Mozilla better.

Can anyone reproduce this bug on Windows NT or Windows XP? If so, can you say
what printer you are using? TIA.
setting status to NEW since there is obviously a problem here and reporter knows 
what he's doing.

We really need QA on NT here.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
(Reporter)

Comment 24

17 years ago
as I mentioned in http://bugzilla.mozilla.org/show_bug.cgi?id=95495#c19
the nightly I tried between 0.9.6 ahd 0.9.7 blew up trying to load the
page in question, so I said I'd retry it on 0.9.7.

I just did.  Same symptoms as 0.9.6 (output-to-be is visible in print
preview, but attempting to print brings up the requester that says
Printing failed for same reason).
(Reporter)

Comment 25

17 years ago
(this is the original reporter, rpraetorius@aspenres.com)

WFM with 0.9.8
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 26

17 years ago
verified.
Status: RESOLVED → VERIFIED
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.