[accessibility] Pressing applications key/shift+f10 on tab focuses input box

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
2 months ago

People

(Reporter: bugzilla, Unassigned)

Tracking

x86
Windows XP

Details

(Reporter)

Description

5 years ago
*** Original post on bio 1635 by James Teh <jamie AT nvaccess.org> at 2012-08-09 12:58:00 UTC ***

Str:
1. Focus on the tab control for switching conversations.
2. Press the applications key or shift+f10 to open the context menu for the tab.
Expected: The context menu for the tab should open.
Actual: The input box gets focus before the key is handled.

This makes it impossible to open the context menu for a tab from the keyboard.

Comment 1

5 years ago
*** Original post on bio 1635 at 2012-08-12 23:48:05 UTC ***

(In reply to comment #0)
> Str:
> 1. Focus on the tab control for switching conversations.

Do you mean focus on a conversation tab itself? Or some other control?

> 2. Press the applications key or shift+f10 to open the context menu for the
> tab.
> Expected: The context menu for the tab should open.

I can't reproduce this - using the context menu key or Sh-F10 on my keyboard, the context menu opens. What do you mean by "applications key"?
(Reporter)

Comment 2

5 years ago
*** Original post on bio 1635 by James Teh <jamie AT nvaccess.org> at 2012-08-12 23:58:23 UTC ***

(In reply to comment #1)
> > 1. Focus on the tab control for switching conversations.
> Do you mean focus on a conversation tab itself?
Yes.

> > 2. Press the applications key or shift+f10 to open the context menu for the
> > tab.
> > Expected: The context menu for the tab should open.
> I can't reproduce this - using the context menu key or Sh-F10 on my keyboard,
> the context menu opens.
If you press it while focused on the tab itself, focus moves to the input box, then the context menu for the input box opens (probably because the key gets forwarded to that). Instead, the context menu for the tab itself should popen. (Btw, i wasn't sure whether the context menu for the input box was open, even though I suspected it, because of bug 955066 (bio 1636). However, I just had a sighted person confirm this.)

> What do you mean by "applications key"?
The Applications key is the key next to the right Windows key on many Windows keyboards. Its sole purpose is to open context menus, so I guess "context menu key" is a different name for the same key. :)

Comment 3

5 years ago
*** Original post on bio 1635 at 2012-08-13 10:01:45 UTC ***

(In reply to comment #2)
In that case we were talking about the same thing, but I can't reproduce it on Linux.
*** Original post on bio 1635 at 2012-08-13 10:09:05 UTC ***

I can confirm this happens on Windows 7 with both the application/context menu key and Shift+F10.
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Original post on bio 1635 at 2012-08-13 12:36:12 UTC ***

(In reply to comment #4)
> I can confirm this happens on Windows 7...
And Windows 8.

See http://lxr.instantbird.org/instantbird/source/instantbird/content/conversation.xml#909 for the method that deals with handling keypress events on the browser of a conversation. (Also...we should remove those ifdefs...)
OS: Windows 7 → Windows XP
Summary: Pressing applications key/shift+f10 on tab focuses input box → [accessibility] Pressing applications key/shift+f10 on tab focuses input box

Comment 6

5 years ago
*** Original post on bio 1635 at 2012-08-13 13:48:03 UTC ***

(In reply to comment #5)
Yes, but for this bug one should investigate the tabbrowser equivalent
http://lxr.instantbird.org/instantbird/source/instantbird/content/tabbrowser.xml#269

Comment 7

5 years ago
*** Original post on bio 1635 at 2012-10-17 18:37:29 UTC ***

Could someone on Windows look into this? ;)
On the behalf of Florian:
Closing bugs related to the Instantbird UI as WONTFIX, as the development of the standalone chat client Instantbird has stopped. Instantbird users are encouraged to migrate to Thunderbird. The user interface of instant messaging in Thunderbird will feel familiar, as the Thunderbird IM support started as a fork of Instantbird.
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
On the behalf of Florian:
Closing bugs related to the Instantbird UI as WONTFIX, as the development of the standalone chat client Instantbird has stopped. Instantbird users are encouraged to migrate to Thunderbird. The user interface of instant messaging in Thunderbird will feel familiar, as the Thunderbird IM support started as a fork of Instantbird.
On the behalf of Florian:
Closing bugs related to the Instantbird UI as WONTFIX, as the development of the standalone chat client Instantbird has stopped. Instantbird users are encouraged to migrate to Thunderbird. The user interface of instant messaging in Thunderbird will feel familiar, as the Thunderbird IM support started as a fork of Instantbird.
You need to log in before you can comment on or make changes to this bug.