If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[FEATURE] handleEvent() is not implemented

VERIFIED WONTFIX

Status

()

Core
DOM: Core & HTML
P3
normal
VERIFIED WONTFIX
19 years ago
18 years ago

People

(Reporter: Prashant Desale, Assigned: joki (gone))

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE] window.handleEvent() must be implemented)

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
Method window.handleEvent() is returning undefined.

PRODUCT: Seamonkey [Apprunner/Viewer]
BUILD: 07-08-08.
OS: Win95, WinNT, Win98, MacOS.

STEPS TO REPRODUCE:
1] Please copy code I'm providing. Save as HTML file.
2] Open this HTML file in Apprunner as well as Viewer.
3] You'll see the return value of window.handleEvent() getting printed on
screen.

NOTE: In actual code [testcase] the method is used without parantheses in order
to know what it is exactly.

EXPECTED RESULTS:
window.handleEvent() = function handleEvent() { [native code] }

ACTUAL RESULTS:
window.handleEvent() = undefined

CODE:

<html>
<head>
<title>Test Page</title>
</head>
<body>
<form name="workform">
<SCRIPT LANGUAGE="JavaScript">
document.writeln("window.handleEvent() = ");
document.writeln(window.handleEvent);
</SCRIPT>
</form>
</body>
</html>

END OF CODE

Comment 1

19 years ago
Created attachment 802 [details]
desale's test case as attachment for convenience

Updated

19 years ago
Whiteboard: [TESTCASE] window.handleEvent() must be implemented

Comment 2

19 years ago
yet another. updated status to "[TESTCASE]..." standard.

Comment 3

19 years ago
Created attachment 803 [details]
desale's test case as attachment for convenience

Comment 4

19 years ago
sorry, wrong window. please ignore attachment #803 [details] :-(
(Reporter)

Comment 5

18 years ago
Its not only for window.handleEvent. Its not yet implemented for any object.
This method does not seem implemented for anyother objects also like button,
checkbox, and so on...
(Reporter)

Updated

18 years ago
Summary: window.handleEvent() is returning undefined → handleEvent() is not implemented
(Reporter)

Comment 6

18 years ago
Changing summary.
Vidur, is this yours or joki's?
Sorry, Tom.  Vidur says you probably have dups of these bugs already, so it
shouldn't hurt _too_ much.
(Assignee)

Updated

18 years ago
Target Milestone: M13
Summary: handleEvent() is not implemented → [FEATURE] handleEvent() is not implemented
Target Milestone: M13 → M14
Moving M14.
(Assignee)

Updated

18 years ago
Target Milestone: M14 → M13
(Assignee)

Comment 10

18 years ago
Moving 4.x event system features back to M13
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M13 → M14
(Assignee)

Comment 11

18 years ago
Well the 4.x event stuff is done but its untested.  Given that I had to make
several changes to general event handling I think I'll take the conservative
road this time and save this till the tree opens for M14.
Bulk moving [testcase] code to new testcase keyword. Sorry for the spam!
Keywords: testcase
(Reporter)

Updated

18 years ago
Keywords: beta1

Comment 13

18 years ago
Please give an example of a top100 page which uses this?  Otherwise, we will 
mark [PDT-]

Comment 14

18 years ago
Info provided by desale via mail when asked WHY FOR BETA?:
"Its not that beta would really suck without it, but its like one feature. 
Without it, we'll be totally missing the user defined ways of handling events. 
I mean, not lot of people use it, but there are some developers who use it. 

No its not blocking QA automation or anything.  I just thought it would be 
better to have this one." 

Comment 15

18 years ago
PDT- for b1
Whiteboard: [TESTCASE] window.handleEvent() must be implemented → [PDT-][TESTCASE] window.handleEvent() must be implemented
(Assignee)

Comment 16

18 years ago
The function is implemented but we're still deciding how this will work in the 
new world.  Pushing to a later milestone.
Target Milestone: M14 → M18
(Reporter)

Comment 17

18 years ago
Adding nsbeta2 to keywords.
Keywords: nsbeta2
Whiteboard: [PDT-][TESTCASE] window.handleEvent() must be implemented → [TESTCASE] window.handleEvent() must be implemented

Comment 18

18 years ago
Putting on [nsbeta2+][6/01] radar.  This work must be done by 06/01 or we may 
pull this for PR2.
Whiteboard: [TESTCASE] window.handleEvent() must be implemented → [nsbeta2+][6/01][TESTCASE] window.handleEvent() must be implemented
joki, could you provide info on the following?
1) handleEvent() is part of the Nav4 DOM but not part of the W3C DOM?
2) handleEvent() duplicates functionality that exist already in a feature of the 
W3C DOM and provides no additional functionality the W3C DOM doesn't offer?
3) If we check in handleEvent(), do we expect to be able to provide full b.c. 
with the behavior of handleEvent() in Nav4, or will it be an inexact emulation 
of the old behavior that therefore appears buggy to the developer?
4) How much more work do you have to do to "finish" handleEvent() to the point 
of providing full b.c.?

JS that used Nav4-specific features will typically need to be rewritten anyway. 
A "buggy" or "partial" emulation is probably worse than not doing it at all if 
equivalent functionality is available through the W3C DOM. If you have much work 
left to do on this, if b.c. will be less than complete, and/or if equivalent 
functionality is available through the W3C DOM, it's tempting to bite the bullet 
and drop this completely so you can focus on debugging our W3C DOM support and 
getting that right. I'd rather do whatever W3C DOM1/2 functionality we 
offer fully debugged than have partial, buggy support of both W3C DOM and Nav4 
DOM features. Thoughts?

Comment 20

18 years ago
Changing from [6/01] to [6/15]
Whiteboard: [nsbeta2+][6/01][TESTCASE] window.handleEvent() must be implemented → [nsbeta2+][6/15][TESTCASE] window.handleEvent() must be implemented
Per recent PDT triage, clearing [nsbeta2+][6/15] and closing as WONTFIX. 
handleEvent() was a proprietary Nav4 event handling method and is OUT for good. 
We will not attempt to provide b.c. with handleEvent() because the W3C DOM2 
offers equivalent functionality through dispatchEvent(), which is already in. 
Will update http://home.netscape.com/browsers/future/standards.html to start 
informing developers how to do the upgrade.

cc:ing dannyg as an FYI.
Whiteboard: [nsbeta2+][6/15][TESTCASE] window.handleEvent() must be implemented → [TESTCASE] window.handleEvent() must be implemented
Sorry, marking WONTFIX for real this time.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 23

18 years ago
As per Eric Krock's comments, Marking it Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.