Closed Bug 955231 Opened 10 years ago Closed 10 years ago

Update libqq-pidgin to 0.72

Categories

(Chat Core :: Debug, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: bugzilla, Assigned: clokep)

Details

Attachments

(3 files, 2 obsolete files)

*** Original post on bio 1798 by Rodrigo Santos <rosonline AT r7.com> at 2012-11-15 10:34:00 UTC ***

*** Due to BzAPI limitations, the initial description is in comment 1 ***
*** Original post on bio 1798 as attmnt 2090 by rosonline AT r7.com at 2012-11-15 10:34:00 UTC ***

I was testing the protocols on the Instantbird 1.3 (pt-BR) when this message  appears: "Dear user, your version of QQ international will be obsolete soon. Please download the latest version to avoid interruption of service. Thank you!"

This error happens when I try to connect my QQ account.
*** Original post on bio 1798 at 2012-11-16 18:02:11 UTC ***

This looks like we need to update our libqq version. I probably still have this [1] checked out somewhere...

[1] http://code.google.com/p/libqq-pidgin/
Assignee: nobody → clokep
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: Error while connects to QQ account → Update libqq-pidgin to 0.72
Attached patch Update to QQ (obsolete) — Splinter Review
*** Original post on bio 1798 as attmnt 2116 at 2012-11-21 19:54:00 UTC ***

This updates libqq to the newest from upstream. I still cannot connect with this patch applied.
Attached patch Changes to libqq (obsolete) — Splinter Review
*** Original post on bio 1798 as attmnt 2117 at 2012-11-21 19:55:00 UTC ***

Changes to libqq after importing it
*** Original post on bio 1798 at 2012-11-22 00:09:28 UTC ***

Comment on attachment 8353878 [details] [diff] [review] (bio-attmnt 2117)
Changes to libqq

>diff --git a/purple/libpurple/protocols/qq/qq_base.c b/purple/libpurple/protocols/qq/qq_base.c

>@@ -1340,10 +1342,8 @@ void qq_clean_group_buddy_list( PurpleCo
> 			qq_room_remove(gc, rmd->id);
> 		}
> 	}
> 	
> 	g_free(list);
> 
> 
> }
>-
>-

This looks like a change you should revert (stupid way to make your changes bitrot easily with the next update...).

>diff --git a/purple/libpurple/protocols/qq/qq_network.c b/purple/libpurple/protocols/qq/qq_network.c
>--- a/purple/libpurple/protocols/qq/qq_network.c
>+++ b/purple/libpurple/protocols/qq/qq_network.c
>@@ -707,16 +707,17 @@ static void set_all_keys(PurpleConnectio
> {
> 	qq_data *qd;
> 	const gchar *passwd;
> 	guint8 *dest;
> 	int dest_len = QQ_KEY_LENGTH;
> #ifndef DEBUG
> 	int bytes;
> #endif
>+  unsigned char source[24] = {0};
> 	/* _qq_show_socket("Got login socket", source); */

The indent is wrong here. Most libpurple files use tabs for indentation.
Attached patch Update to QQ v2Splinter Review
*** Original post on bio 1798 as attmnt 2145 at 2012-11-30 02:27:00 UTC ***

So I have no idea how I attached this last time since...it doesn't compile. :-[ I'm sorry about that. Note that this will actually conflict with bug 954410 (bio 976).

This crashes with a heap error. :-/
Comment on attachment 8353877 [details] [diff] [review]
Update to QQ

*** Original change on bio 1798 attmnt 2116 at 2012-11-30 02:27:03 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8353877 - Attachment is obsolete: true
*** Original post on bio 1798 as attmnt 2146 at 2012-11-30 02:28:00 UTC ***

This fixes the spacing issues from comment 4.
Comment on attachment 8353878 [details] [diff] [review]
Changes to libqq

*** Original change on bio 1798 attmnt 2117 at 2012-11-30 02:28:03 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8353878 - Attachment is obsolete: true
*** Original post on bio 1798 at 2012-12-21 01:06:52 UTC ***

Unless we have positive reports that this upgrade will fix QQ support (i.e. by using it in Pidgin) I probably won't work on this further.
Status: ASSIGNED → NEW
Or maybe switch this to https://github.com/xiehuc/pidgin-lwqq
We've disabled QQ support in Instantbird. If someone is willing to do the work to add something back, they should open a new bug.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: