OBJECT tag's type can't be changed later (like through the DOM)

RESOLVED FIXED in Future

Status

()

P4
normal
RESOLVED FIXED
18 years ago
13 years ago

People

(Reporter: peterlubczynski-bugs, Assigned: peterlubczynski-bugs)

Tracking

Trunk
Future
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PL2:P4][Object][Hixie-P4])

(Assignee)

Description

18 years ago
This is from bug 678 which implemented document viewing with the OBJECT tag. The
problem is that once we create a plugin with an OBJECT (or maybe even EMBED)
tag, we can't later change the kind of plugin we use.

For example, change the TYPE= or DATA= attributes through the DOM and nothing
happens.
Marking dom1.  See also bug 40680 and bug 46569 for some other object-related 
issues...
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla1.0

Comment 2

17 years ago
Bugs targeted at mozilla1.0 without the mozilla1.0 keyword moved to mozilla1.0.1 
(you can query for this string to delete spam or retrieve the list of bugs I've 
moved)
Target Milestone: mozilla1.0 → mozilla1.0.1
is this still being planned for 1.0.1?  Some sites like to change the file to be
embedded via a select, and since we can't script say windows mp, this would
offer us a possibilty to circumvent that issue.

Comment 4

17 years ago
1.2
Whiteboard: [Object]
Target Milestone: mozilla1.0.1 → mozilla1.2alpha
Whiteboard: [Object] → [Object][Hixie-P4]

Updated

17 years ago
Priority: P3 → P4
Whiteboard: [Object][Hixie-P4] → [PL2:P4][Object][Hixie-P4]
Target Milestone: mozilla1.2alpha → Future
(Assignee)

Comment 5

16 years ago
*** Bug 96568 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 6

16 years ago
The current workaround for this is to remove the old node before attaching the
new one. Also see bug 192891.
Status: ASSIGNED → NEW
fixed by bug 1156, although all changes only take effect once you change .data
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Depends on: 1156
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.