Nightlies depend on gcc >= 4.5 via libstdc++

VERIFIED FIXED in 1.5

Status

Chat Core
General
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: aleth, Assigned: florian)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [1.5-nice-to-have])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
*** Original post on bio 2140 at 2013-08-29 14:11:00 UTC ***

"/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.14' not 
found (required by ./libxul.so)"

http://glandium.org/blog/?p=1901 explains the problem and how it was solved for FX.
(Reporter)

Updated

5 years ago
Whiteboard: [1.5-wanted]
(Reporter)

Updated

5 years ago
Whiteboard: [1.5-wanted] → [1.5-blocking]
(Reporter)

Updated

5 years ago
Blocks: 955560
*** Original post on bio 2140 at 2013-11-22 07:09:49 UTC ***

As annoying as this is, I don't think I would hold the 1.5 release for it.
Whiteboard: [1.5-blocking] → [1.5-nice-to-have]
(Reporter)

Comment 2

5 years ago
*** Original post on bio 2140 at 2013-11-22 11:22:46 UTC ***

Is it known whether this is a problem with the particular set of packages installed on the build slave, or whether it is a configuration problem as described in the above blogpost?
*** Original post on bio 2140 at 2013-11-22 11:40:56 UTC ***

I don't remember, but aren't the changes mentioned in that blog post things that have been commited in mozilla-central and that we don't need to do anything about?
Created attachment 8354871 [details] [diff] [review]
Patch

*** Original post on bio 2140 as attmnt 3089 at 2013-11-28 12:12:00 UTC ***

This is my best guess at this point.
(Reporter)

Comment 5

5 years ago
Comment on attachment 8354871 [details] [diff] [review]
Patch

*** Original change on bio 2140 attmnt 3089 at 2013-11-28 12:13:16 UTC was without comment, so any subsequent comment numbers will be shifted ***
Attachment #8354871 - Flags: review+
*** Original post on bio 2140 at 2013-11-28 12:55:13 UTC ***

Hopefully this fixes the issue. Let's reopen this bug if it doesn't.

http://hg.instantbird.org/instantbird/rev/4e714a9b18a6
Assignee: nobody → florian
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.5
*** Original post on bio 2140 at 2013-11-29 08:54:37 UTC ***

I verified that the libxul.so of the new nightly (that failed at the package step; but had libxul.so compiled) doesn't import the GLIBCXX_3.4.14 and GLIBCXX_3.4.9 symbols any more.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.