If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Can't get through Microsoft Proxy Server

VERIFIED DUPLICATE of bug 35159

Status

()

Core
Networking
--
blocker
VERIFIED DUPLICATE of bug 35159
16 years ago
16 years ago

People

(Reporter: Paul, Assigned: neeti)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.0; Windows 98; DigExt)
BuildID:    2001080814

I live in a large company, which use a Microsoft Proxy server to get an access 
to internet. I am in a small group which is using unix computers (AIX, Solaris, 
Linux, IRIX). All windows office PC can connect to internet with IE but 
everybody else cannot. I have tried it on any netscape/mozila version. When 
using opera I got an error "Unknown authentication method". when using MS IE 
5.0 for Solaris 2.6 I could get through.
I cannot change anything on the server side, they don't like unix at all.
Description:
I have filled in a proxy access. When I tried to access any page I got no 
user/password window or any other error, just a blank screen with 
<html><head><title>Error</title></head><body> as text in it.

I think the problem is in a authentication, internet access is authenticated 
against NT domain users and this is supported only by IE. 

Reproducible: Always
Steps to Reproduce:
1. Set up an Microsoft Proxy server with authentication and hate unix.
2. Try to get through.
3.

Actual Results:  No page.

Comment 1

16 years ago
Dup of bug 35159 and bug 23679 . Mozilla doesn't support NTLM, the
authentication method used by the M$ Proxy (and IIS). Neither does any other
browser, Netscape included.

It's in the release notes, btw.

Comment 2

16 years ago
Agreed.

*** This bug has been marked as a duplicate of 35159 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 3

16 years ago
VERIFIED:
someone read the release notes? wow, I gotta show this to my boss...
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

16 years ago
Hi,
for everybody interested in this NTLM Authentication problem. Please have a 
look at http://www.geocities.com/rozmanov/ntlm/ There is a solution !!!

Have a nice day.

Paul.
You need to log in before you can comment on or make changes to this bug.