Nightly builds of Instantbird are no longer updating

RESOLVED WORKSFORME

Status

--
blocker
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
*** Original post on bio 285 by Michael <Prescience500 AT gmail.com> at 2009-12-13 09:08:00 UTC ***

Steps to Reproduce:
1) Click Help > Check for Updates...
2) Click the Ok button
3) Click the Restart button

Expected Results:
Instantbird installs the downloaded update.

Actual Results:
Instantbird is unable to install the downloaded update.

Workaround:
Download Instantbird from the nightly server, unzip it and paste it onto where the current Instantbird folder is.

Note:
I think this broke around the time I saw the change log say something about a windows installer being added. This bug is on Windows XP
*** Original post on bio 285 at 2009-12-13 11:02:10 UTC ***

Did you notice this most recently or some time ago?

A full update yesterday and a partial update today worked for me without any problems.

Comment 2

5 years ago
*** Original post on bio 285 at 2009-12-13 11:06:16 UTC ***

I just tested this point. It works fine.

There was no nightlies for a few days recently. Maybe you misunderstood no updating because no new version with a bug.

Marked as invalid and moved to product Instantbird component updates.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Component: update.instantbird.org → Other
Product: Instantbird Servers → Instantbird
Resolution: --- → INVALID
Version: unspecified → trunk
*** Original post on bio 285 at 2009-12-13 11:29:37 UTC ***

I had to download the new nightly once or twice this month, I couldn't figure out why my local build was unable to update, but the current builds are able to update correctly so... I don't think we can do anything for now.

This is not specific to Windows XP, I had this problem on Mac OS X 10.5, and I know Idechix had it on ubuntu.
OS: Other → All
Hardware: x86 → All
Resolution: INVALID → WORKSFORME
(Reporter)

Comment 4

5 years ago
*** Original post on bio 285 by Michael <Prescience500 AT gmail.com> at 2009-12-13 12:22:30 UTC ***

This hasn't been working for me for weeks. I didn't report it sooner because there's been a few times i had to manually update in the past, but it was fixed in a few days. In this case, i would tell it to update, it would download, restart, and then tells me it failed. I tell it to do a full instead of a partial update which fails. I try a couple more times and it would fail every time. This has been going on for a while, even before the trunk stopped producing builds. I've been manually downloading from server, unzipping and pasting it into the Instantbird folder since it stopped updating.

On second thought, maybe something has been corrupted on my computer, I've deleted Instantbird, and all related files and folders in "my documents and settings" and replaced it with a fresh build. Maybe that will fix it for when the trunk starts producing builds again.
*** Original post on bio 285 at 2009-12-13 12:27:08 UTC ***

Ok. If the problem persists, let us know. In this case we will really need to find a way to investigate the issue.
(Reporter)

Comment 6

5 years ago
*** Original post on bio 285 by Michael <Prescience500 AT gmail.com> at 2009-12-17 09:50:36 UTC ***

Okay, after taking the measures I mentioned previously, it's still failing to update. This is on Windows XP SP3. I don't know any programing, but I'd like to help find the issue. Unfortunately, the error console doesn't stay open when Instantbird closes to attempt to install the update. Are there any diagnostics or anything I can do to help find the problem?
*** Original post on bio 285 at 2010-04-19 21:29:43 UTC ***

The underlying issue is covered by https://bugzilla.mozilla.org/show_bug.cgi?id=539717 and is going to be fixed very soon (there's a reviewed patch ready to land) :).
You need to log in before you can comment on or make changes to this bug.