Blurry render of css background images positioned with background-position and scaled with background-size

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
5 years ago
4 months ago

People

(Reporter: xslade, Unassigned)

Tracking

26 Branch
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox40 unaffected)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8354952 [details]
demo.png

User Agent: Opera/9.80 (Windows NT 6.1; WOW64) Presto/2.12.388 Version/12.16

Steps to reproduce:

Set a background-image css property.
Set background-position in percentage (eg. 50% 50%)
Scale it with background-size.
The same behavior for both png and jpg.


Actual results:

Background image looks blurry. And if you set background-position in pixels everything looks just fine.
Demo: http://sladex.org/bugzilla/blurry/


Expected results:

Sharp scaled image, like in Chrome.

Updated

5 years ago
Component: Untriaged → ImageLib
Product: Firefox → Core

Comment 1

5 years ago
image.high_quality_downscaling.enabled = false helps

Updated

5 years ago
Blocks: 486918
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

5 years ago
Confirmed the issue with 29. Workaround would be using viewport units but hope they find a fix soon.

Updated

4 years ago
Blocks: 1081206

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX

Comment 3

3 years ago
Could you please explain why you WONTFIXed this bug?
Flags: needinfo?(hcondei)
Yes, I'd like to know that too. Also, why did you WONTFIX bug 1081206, which this bug blocks?
(As long as I'm at it, the component is definitely wrong on this bug.)
Component: ImageLib → Layout: Images

Comment 6

3 years ago
FWIW, the test case does not reproduce this bug on my Firefox 39.0.3 (32-bit). So maybe it should be worksforme instead of fixed?

Comment 7

3 years ago
Hi! Sorry for late reply, seen need info just now, due to last comment. I tried reproducing it on FF 39.0.3 (also on FF 40 now, just to make sure) and it doesn't reproduce. My bad for marking it wontfix instead of work for me. Also, I'll make sure to comment when making changes next time.
Flags: needinfo?(hcondei)
Resolution: WONTFIX → WORKSFORME

Updated

3 years ago
status-firefox40: --- → unaffected
(Reporter)

Comment 8

3 years ago
Hi there! Checked on Windows 10 + FF 40, Windows 7 + FF 38 (and 40), Mac OS + FF 40. Doesn't reproduce.

Updated

4 months ago
Product: Core → Core Graveyard

Updated

4 months ago
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.