If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Nightly - NoScript Button Moves on Restart

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: L.A.R. Grizzly, Unassigned)

Tracking

(Blocks: 1 bug)

29 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20131231030203

Steps to reproduce:

I'm having an issue with my NoScript button. I usually have it to the left of the Location Window on my Nav Bar and when Nightly is relaunched, it moves to the right of the Location Window. This has only been happening with the last few builds. All my other Nav Bar buttons remain where placed.

Reference: http://forums.mozillazine.org/viewtopic.php?f=23&t=2787287


Actual results:

NoScript Button moves on Nav Bar with relaunch of browser.


Expected results:

NoScript Button should remain where placed on Nav Bar.
(Reporter)

Comment 1

4 years ago
This bug may be fixed. I was advised to delete my localstore.rdf file in an attempt to fix the problem. So far, it has worked. I'll give it a few days before closing this bug.
Blocks: 942157
Blocks: 908549

Comment 2

4 years ago
(In reply to L.A.R. Grizzly from comment #1)
> This bug may be fixed. I was advised to delete my localstore.rdf file in an
> attempt to fix the problem. So far, it has worked. I'll give it a few days
> before closing this bug.

Did you keep an archive of that file? We keep information about placement of buttons elsewhere; I'm not sure how that file would still be influencing the placement of buttons, and would be interested to see a copy in order to figure out what was going on... even if deleting it helped, we won't be deleting the file for everyone, and so it'd be good if we could figure out what was broken with the old file there, and fix it. :-)
Flags: needinfo?(grizzly)

Comment 3

4 years ago
Yuren Yu, did you really mean to make this block bug 908549? I suspect you meant another bug; I don't see this bug having anything to do with gaia.
No longer blocks: 908549
Flags: needinfo?(yurenju.mozilla)
Hi Gijs, sorry I make a wrong dependency.

thank you for removing that.
Flags: needinfo?(yurenju.mozilla)
(Reporter)

Comment 5

4 years ago
(In reply to :Gijs Kruitbosch from comment #2)
> (In reply to L.A.R. Grizzly from comment #1)
> > This bug may be fixed. I was advised to delete my localstore.rdf file in an
> > attempt to fix the problem. So far, it has worked. I'll give it a few days
> > before closing this bug.
> 
> Did you keep an archive of that file? We keep information about placement of
> buttons elsewhere; I'm not sure how that file would still be influencing the
> placement of buttons, and would be interested to see a copy in order to
> figure out what was going on... even if deleting it helped, we won't be
> deleting the file for everyone, and so it'd be good if we could figure out
> what was broken with the old file there, and fix it. :-)

Yes, I still have a copy of the file from one of my profile backups. Let me know where to send it or how to make it available to the devs.
Flags: needinfo?(grizzly)

Comment 6

4 years ago
(In reply to L.A.R. Grizzly from comment #5)
> (In reply to :Gijs Kruitbosch from comment #2)
> > (In reply to L.A.R. Grizzly from comment #1)
> > > This bug may be fixed. I was advised to delete my localstore.rdf file in an
> > > attempt to fix the problem. So far, it has worked. I'll give it a few days
> > > before closing this bug.
> > 
> > Did you keep an archive of that file? We keep information about placement of
> > buttons elsewhere; I'm not sure how that file would still be influencing the
> > placement of buttons, and would be interested to see a copy in order to
> > figure out what was going on... even if deleting it helped, we won't be
> > deleting the file for everyone, and so it'd be good if we could figure out
> > what was broken with the old file there, and fix it. :-)
> 
> Yes, I still have a copy of the file from one of my profile backups. Let me
> know where to send it or how to make it available to the devs.

Hrm. L.A.R. Grizzly sent me a copy of the file; even with it I'm having trouble reproducing. I noticed it initially moving to the end of the navbar after migrating from Aurora (because there it was on the add-on bar, as far as I can tell?) but then after customizing it and restarting, it seemed to be in the right place. The only other thing I can imagine is that the preferences file (prefs.js) is not getting saved somehow...

If you copy that file back into the profile, does the problem reoccur?

Comment 7

4 years ago
Whoops, meant to needinfo...
Flags: needinfo?(grizzly)
(Reporter)

Comment 8

4 years ago
(In reply to :Gijs Kruitbosch from comment #6)
> (In reply to L.A.R. Grizzly from comment #5)
> > (In reply to :Gijs Kruitbosch from comment #2)
> > > (In reply to L.A.R. Grizzly from comment #1)
> > > > This bug may be fixed. I was advised to delete my localstore.rdf file in an
> > > > attempt to fix the problem. So far, it has worked. I'll give it a few days
> > > > before closing this bug.
> > > 
> > > Did you keep an archive of that file? We keep information about placement of
> > > buttons elsewhere; I'm not sure how that file would still be influencing the
> > > placement of buttons, and would be interested to see a copy in order to
> > > figure out what was going on... even if deleting it helped, we won't be
> > > deleting the file for everyone, and so it'd be good if we could figure out
> > > what was broken with the old file there, and fix it. :-)
> > 
> > Yes, I still have a copy of the file from one of my profile backups. Let me
> > know where to send it or how to make it available to the devs.
> 
> Hrm. L.A.R. Grizzly sent me a copy of the file; even with it I'm having
> trouble reproducing. I noticed it initially moving to the end of the navbar
> after migrating from Aurora (because there it was on the add-on bar, as far
> as I can tell?) but then after customizing it and restarting, it seemed to
> be in the right place. The only other thing I can imagine is that the
> preferences file (prefs.js) is not getting saved somehow...
> 
> If you copy that file back into the profile, does the problem reoccur?

Yes! I copied my problem localstore.rdf file into my current working profile and as soon as I opened Nightly, my NoScript button was place immediately to the right of the Location Window!
Flags: needinfo?(grizzly)
(Reporter)

Comment 9

4 years ago
I'm considering this bug RESOLVED. I've had no more trouble with my NoScript button since rebuilding my localstore.rdf file.

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.