bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

[Bluetooth] Redial call via BT headset only works for the first time, after that it will only play music when press same button combination..

VERIFIED DUPLICATE of bug 952893

Status

Firefox OS
Bluetooth
VERIFIED DUPLICATE of bug 952893
5 years ago
5 years ago

People

(Reporter: Enpei, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dsdsrun1.3-2)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8355118 [details]
time stamp: 13:54, 1/2.

When press call button on BT headset twice, device will redial call from call history for the first time. After that, pressing same button twice will only launch Music app to play music.

* Build Number                
Gaia      01e9da49be2cc4bc134eeefc434740d572ec2246
Gecko     http://hg.mozilla.org/releases/mozilla-aurora/rev/61f553e5db49
BuildID   20140101004001
Version   28.0a2

* BT headset: HTC BH S600

* Reproduce Steps
1. Paired BT headset.
2. Make sure there is call record in call history.
3. Press call button twice on BT headset.
4. Call will be dialed out. Then end this call.
5. Press call button twice on BT headset again.

* Expected Result
Call will be dialed out.

* Actual Result
Music is played. 

* Occurrence rate
100%.
This bug is blocking by Bug 952893.

Root caused:
Dialer app would continue to send audio stream (silent samples) after the function tp_ensureAudio() was called by dialer/js/tone_player.js. BT headset wouldn't sent redail command if FxOS phone keeps sending audio stream.  

The bug can only be reproduced in v1.4 since the Moz Audio API was replaced by Web Audio API in Bug 927852. The double click re-dailing works fine if the change of Bug 927852 is reverted.
Blocks: 952893
No longer blocks: 952893
Depends on: 952893
(Reporter)

Updated

5 years ago
Whiteboard: dsdsrun1.3-2
The blocking bug 952893 was resolved.
The redial behavior works fine with current codebase.

Build:
Gaia  ac94739a01d64e86890f54f1795ff8e82b8e7939                           │  
Gecko https://hg.mozilla.org/mozilla-central/rev/2c366892729d  

B2G Device:
Inari

BT headset:
HTC BH S600
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 952893
Thanks for confirming this, Jamin.
(Reporter)

Comment 4

5 years ago
Verified. 
Fugu
Gaia      bb36b4164d3e51ca04b612e507e1178f80bf240d
Gecko     4227240a4d3e1e418ced160c2a48cb454d7b5645
BuildID   20140204104742
Version   28.0
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.