Closed Bug 956138 Opened 6 years ago Closed 6 years ago

Have BrowserUITelemetry wait for sessionstore-windows-restored before gathering measurements

Categories

(Firefox :: Toolbars and Customization, defect)

x86
All
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 29
Tracking Status
firefox27 --- fixed
firefox28 --- fixed
firefox29 --- fixed

People

(Reporter: mconley, Assigned: mconley)

References

Details

(Whiteboard: [Australis:P-][qa-])

Attachments

(2 files)

Bug 952180 corrected an issue where most UITelemetry payloads were empty since BrowserUITelemetry was trying to gather window measurements after all of the windows had already been closed.

We corrected that issue by gathering those measurements on the first window that opens, as soon as it paints.

The problem with that approach is that we paint pretty early on, and at that point, certain UI things are not set / ready for measuring. For example, the window sizemode is not guaranteed to be set, nor are the tabs properly populated.

We can get around this problem by waiting for the sessionstore-windows-restored observer notification, and then grab a browser window via RecentWindow for measurements.
Attachment #8355317 - Flags: review?(jaws)
Attachment #8355316 - Flags: review?(jaws)
Attachment #8355316 - Flags: review?(jaws) → review+
Comment on attachment 8355317 [details] [diff] [review]
Patch v1 - for non-Australis

For both of these patches, you need to update the commit message to have [Australis] and [Holly] (or something non-Australis obvious).
Attachment #8355317 - Flags: review?(jaws) → review+
Can do. Thanks for the reviews!
Comment on attachment 8355317 [details] [diff] [review]
Patch v1 - for non-Australis

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 

None. This makes it so that BrowserUITelemetry can correctly read measurements for things that only come into existence after the session has been fully restored.

User impact if declined: 

None - but we don't get things like tab counts, and sizemode measurements.


Testing completed (on m-c, etc.): 

All manual testing.


Risk to taking this patch (and alternatives if risky): 

Very low.


String or IDL/UUID changes made by this patch:

None.
Attachment #8355317 - Flags: approval-mozilla-beta?
Attachment #8355317 - Flags: approval-mozilla-aurora?
Landed on fx-team as https://hg.mozilla.org/integration/fx-team/rev/fa76e7f26c41

Holding off on Holly landing until bug 956108 (the many oranges we have on Holly) is sorted.
Bug 956108 appears to be in the bag, so landed on Holly as https://hg.mozilla.org/projects/holly/rev/d52fe68d2943
https://hg.mozilla.org/mozilla-central/rev/fa76e7f26c41
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Attachment #8355317 - Flags: approval-mozilla-beta?
Attachment #8355317 - Flags: approval-mozilla-beta+
Attachment #8355317 - Flags: approval-mozilla-aurora?
Attachment #8355317 - Flags: approval-mozilla-aurora+
Whiteboard: [Australis:P-] → [Australis:P-][qa-]
You need to log in before you can comment on or make changes to this bug.