Decrease the browser window's minimum width in pre-Australis Firefox

RESOLVED FIXED in Firefox 27

Status

()

Firefox
General
RESOLVED FIXED
4 years ago
2 years ago

People

(Reporter: dao, Assigned: dao)

Tracking

27 Branch
Firefox 27
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox26 wontfix, firefox27 fixed, firefox28 fixed, firefox29 unaffected)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
Bug 897160 set a minimum width on the browser window based on Australis constraints, but landed it in pre-Australis Firefox where the used width is over-zealous and users are understandably complaining about it.

Bug 897160 comment 61 suggests that 250 would be a reasonable value to adopt. I think we should do this on Beta, Aurora and the Holly branch.
(Assignee)

Comment 1

4 years ago
Created attachment 8355495 [details] [diff] [review]
patch
Attachment #8355495 - Flags: review?(jaws)
(Assignee)

Updated

4 years ago
Summary: Increase the browser window's minimum width in pre-Australis Firefox → Decrease the browser window's minimum width in pre-Australis Firefox
Comment on attachment 8355495 [details] [diff] [review]
patch

Review of attachment 8355495 [details] [diff] [review]:
-----------------------------------------------------------------

We could do this on Aurora and Beta, but I'd rather not do it on Holly because it touches browser/base/content/browser.css and that can make future merges more difficult.
Attachment #8355495 - Flags: review?(jaws) → review+
(Assignee)

Comment 3

4 years ago
Comment on attachment 8355495 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 897160
User impact if declined: see comment 0
Testing completed (on m-c, etc.): this patch is only for aurora & beta
Risk to taking this patch (and alternatives if risky): no risk
String or IDL/UUID changes made by this patch: none
Attachment #8355495 - Flags: approval-mozilla-beta?
Attachment #8355495 - Flags: approval-mozilla-aurora?

Updated

4 years ago
Attachment #8355495 - Flags: approval-mozilla-beta?
Attachment #8355495 - Flags: approval-mozilla-beta+
Attachment #8355495 - Flags: approval-mozilla-aurora?
Attachment #8355495 - Flags: approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/10dd4e9b13fb
https://hg.mozilla.org/releases/mozilla-beta/rev/2fb364c9bfd1

I'm assuming Australis will ship in 29. If it doesn't, we can reopen this and change the status accordingly.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-firefox27: affected → fixed
status-firefox28: affected → fixed
status-firefox29: --- → unaffected
Resolution: --- → FIXED
Target Milestone: --- → Firefox 27
Updated the compat doc accordingly.
https://developer.mozilla.org/en-US/Firefox/Releases/26/Site_Compatibility
Flags: in-testsuite?
(Assignee)

Updated

4 years ago
Flags: in-testsuite? → in-testsuite-
Henrik, given in-testsuite-, I'm wondering if this is something we should be testing in-qa-testsuite?
Flags: in-qa-testsuite?(hskupin)
(In reply to Anthony Hughes, QA Mentor (:ashughes) from comment #6)
> Henrik, given in-testsuite-, I'm wondering if this is something we should be
> testing in-qa-testsuite?

Given the lack of a comment I have no idea why in-testsuite has been denied. I would like to get further information from Dao first.
Flags: needinfo?(dao)
(Assignee)

Comment 8

4 years ago
There was no comment when setting in-testsuite? either. What kind of automated test did you have in mind?
Flags: needinfo?(dao)
Forwarding this question to Anthony then...
Flags: needinfo?(anthony.s.hughes)
(In reply to Dão Gottwald [:dao] from comment #8)
> There was no comment when setting in-testsuite? either. What kind of
> automated test did you have in mind?

I'm not sure what framework is appropriate but something to ensure the minimum bounds are being respected.
Flags: needinfo?(anthony.s.hughes)
Removing my name from in-qa-testsuite flag for a better query.
Flags: in-qa-testsuite?(hskupin) → in-qa-testsuite?
Flags: in-qa-testsuite?
You need to log in before you can comment on or make changes to this bug.