Network requests waiting, taking 5 seconds with profile

RESOLVED DUPLICATE of bug 1136484

Status

()

defect
RESOLVED DUPLICATE of bug 1136484
6 years ago
3 years ago

People

(Reporter: BenWa, Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

Posted image Network Monitor
I'm seeing 1-5 seconds network requests in the waiting phase. This seems to be worse on sites I visit a lot and only happens on my primary profile. Using another browser or profile and the sites are snappy to load. I haven't tweaked any non GFX preferences and the time is spent waiting on network (CPU is idle, profiling shows nothing, tabs shows Connecting...).
regression in nightly?
Flags: needinfo?(bgirard)
Keywords: perf
Summary: Network requests taking 5 seconds with profile → Network requests waiting, taking 5 seconds with profile
Nope. I did a regression window but I kept running into the edge of was doesn't run on my machine (likely doesn't run on 10.9):
2010-09-22 (doesn't run)
2010-10-20 (slow request to sites like reddit.com on my profile)
Flags: needinfo?(bgirard)
I reset my profile and this is still happening.

Can anyone try to reproduce this with their existing profile and compare with either a clean profile or Chrome?
I regularly see about 1500ms of latency with reddit - the home page is just slow (chrome confirms). But you're seeing triple that. hmm.

maybe a wireshark capture to see if we're really seeing that much network delay or its being captured at a higher level?
Sure. What commands should I run?
Flags: needinfo?(mcmanus)
http://wiki.wireshark.org/CaptureSetup

basically install wireshark, hit ^E to start the capture, load reddit, and hit ^E to stop the capture. the cap probably has cookies and junk in it - so you can just get a screeenshot of the summary that should show the timing information. If it looks like examining the capture file itself would be handy I'll let you know.
Flags: needinfo?(mcmanus)
Flags: needinfo?(mcmanus)
I can reproduce this. While on reddit.com, I hit enter on the reddit.com URL in the URL bar and the Network analysis devtool always shows at least 1 second being spent waiting on the GET request for reddit.com/ 

- I can reliably reproduce this on Nightly 32
- It does not reproduce on Release 29.0.1
- It does not reproduce in Chrome 35
- It does not reproduce on a fresh profile. I think it might have to be a site frequently visited in the past?
I'm going to bet this is a dup of 1136484
Flags: needinfo?(mcmanus)
best guess of a dup.. please reopen with fresh info if you still see this as a concern
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1136484
You need to log in before you can comment on or make changes to this bug.