Closed Bug 956420 Opened 7 years ago Closed 7 years ago

header on Twitter scrolls incorrectly when viewing images

Categories

(Firefox for Android :: Toolbar, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 29
Tracking Status
firefox27 --- fixed
firefox28 --- fixed
firefox29 --- fixed
fennec + ---

People

(Reporter: blassey, Assigned: cwiiis)

References

()

Details

(Keywords: regression)

Attachments

(2 files)

Attached video header.mp4
see screenshot. not sure if its fixed position or not, regardless its not right.
Steps: https://twitter.com/firefox/status/416976893259182080 and then tap the image.

Testing on my Nexus 5 it doesn't look as bad as is on your device, see video: http://www.youtube.com/watch?v=QzmCr7sbyTs

There's a small gap above the header between the URL-bar and the header still.

Behaviour is different on all channels.
OS: Mac OS X → Android
Hardware: x86 → ARM
Summary: header on twitter scrolls incorrectly → header on Twitter scrolls incorrectly when viewing images
Did bug 940889 regress this at all? Just wondering if we should block that from getting uplifted.
I don't believe bug 940889 is responsible here. I'm also not able to reproduce the issue in comment 0. I can see the issue in comment 1; this appears to be the fixed-position bar lagging a little bit as you scroll.
I'll try to get a testcase
tracking-fennec: ? → +
Flags: needinfo?(mark.finkle)
I see the same behavior on SUMO with the Nexus One, however I can't get a screencast from the Nexus One and the screen on the Nexus 5 is too big for it to be pannable.
Duplicate of this bug: 958439
I think this is a regression, can we get a range?
Not sure how this one slipped through... Could've sworn I tested this exact scenario, but obviously not (unless it regressed at some point).
Assignee: nobody → chrislord.net
Status: NEW → ASSIGNED
Attachment #8360443 - Flags: review?(bugmail.mozilla)
Attachment #8360443 - Flags: review?(bugmail.mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/b1ea2300010c
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
As per the fix and IRC discussion this is not needed anymore.
Comment on attachment 8360443 [details] [diff] [review]
Fix fixed margins on short pages

[Approval Request Comment]
Bug caused by (feature/regressing bug #): This bug
User impact if declined: Weird fixed header behaviour on Twitter (and any site that causes a pinned toolbar)
Testing completed (on m-c, etc.): Tested locally and now on m-c
Risk to taking this patch (and alternatives if risky): Low risk
String or IDL/UUID changes made by this patch: None

Given that Twitter is pretty popular(!), we should probably uplift this patch. I consider it to be pretty low risk.
Attachment #8360443 - Flags: approval-mozilla-beta?
Attachment #8360443 - Flags: approval-mozilla-aurora?
Comment on attachment 8360443 [details] [diff] [review]
Fix fixed margins on short pages

Yes, Twitter is pretty popular and this looks very low risk so let's land today and get this into our second-to-last mobile beta.
Attachment #8360443 - Flags: approval-mozilla-beta?
Attachment #8360443 - Flags: approval-mozilla-beta+
Attachment #8360443 - Flags: approval-mozilla-aurora?
Attachment #8360443 - Flags: approval-mozilla-aurora+
Flags: needinfo?(mark.finkle)
You need to log in before you can comment on or make changes to this bug.