Location app bar pops up when fragment identifier changes (URL stuff after hash / number sign)

VERIFIED FIXED in Firefox 29

Status

defect
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: flamingdescent, Assigned: azasypkin)

Tracking

({polish, ux-interruption})

Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mentor=mbrubeck@mozilla.com][good first bug][lang=js] p=0 r=ff29)

Attachments

(2 attachments)

Reporter

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20140105004002

Steps to reproduce:

1. Go to http://www.haikudeck.com/p/IXPQ9thNi1/10-tips-to-transform-your-presentations#
2. To dismiss the bottom app bar, left click somewhere that isn't a link.
3. Press the next button on the webpage
If you have a Google Account, you can also:
1. Go to http://www.google.com/maps/about/explore/
2. Press "Try it now" on the webpage
3. Press "Sign In" on the webpage, and sign in
4. Press "Click here to start exploring"
5. Drag somewhere to move the map.


Actual results:

The bottom app bar pops up, probably because the URL changed.


Expected results:

The bottom app bar doesn't pop up.
This happens because in the URLChanged event listener here:
http://hg.mozilla.org/mozilla-central/file/cf80c0d4f46e/browser/metro/base/content/ContextUI.js#l318

We should change that code to display the navbar only if aEvent.detail is true.  We set the "detail" property based on the locationHasChanged variable here:
http://hg.mozilla.org/mozilla-central/file/cf80c0d4f46e/browser/metro/base/content/WebProgress.js#l119
Blocks: metrobacklog
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [defect] [mentor=mbrubeck@mozilla.com][good first bug][lang=js]
Whiteboard: [defect] [mentor=mbrubeck@mozilla.com][good first bug][lang=js] → [mentor=mbrubeck@mozilla.com][good first bug][lang=js] [defect] p=0
Assignee: nobody → azasypkin
Status: NEW → ASSIGNED
Attachment #8361778 - Flags: review?(mbrubeck)
Comment on attachment 8361778 [details] [diff] [review]
location appbar v1.diff

Review of attachment 8361778 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!

Could you also add an automated test for this bug?  You can do this in a separate patch.  The test can go in this file:
http://dxr.mozilla.org/mozilla-central/source/browser/metro/base/tests/mochitest/browser_context_ui.js

These tests use the mochitest-browser-chrome framework, which is documented here:
https://developer.mozilla.org/en-US/docs/Browser_chrome_tests
https://wiki.mozilla.org/Firefox/Windows_8_Integration#Testing
Attachment #8361778 - Flags: review?(mbrubeck) → review+
Tests added.
Attachment #8362395 - Flags: review?(mbrubeck)
Attachment #8362395 - Flags: review?(mbrubeck) → review+
https://hg.mozilla.org/integration/fx-team/rev/cec5c572a516
https://hg.mozilla.org/integration/fx-team/rev/6dfa253da690

In the future, please use different commit messages that explain what each patch is individually doing rather than the same one for all.
Flags: in-testsuite+
Keywords: checkin-needed
Whiteboard: [mentor=mbrubeck@mozilla.com][good first bug][lang=js] [defect] p=0 → [mentor=mbrubeck@mozilla.com][good first bug][lang=js] [defect] p=0 [fixed-in-fx-team]
Oh, sure. Sorry about that.
https://hg.mozilla.org/mozilla-central/rev/cec5c572a516
https://hg.mozilla.org/mozilla-central/rev/6dfa253da690
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [mentor=mbrubeck@mozilla.com][good first bug][lang=js] [defect] p=0 [fixed-in-fx-team] → [mentor=mbrubeck@mozilla.com][good first bug][lang=js] [defect] p=0
Target Milestone: --- → Firefox 29
Whiteboard: [mentor=mbrubeck@mozilla.com][good first bug][lang=js] [defect] p=0 → [mentor=mbrubeck@mozilla.com][good first bug][lang=js] p=0 r=ff29
This issue is still reproducible with latest Nightly on Win 8 64-bit with http://www.google.com/maps/about/explore/ but it's fixed for http://www.haikudeck.com/p/IXPQ9thNi1/10-tips-to-transform-your-presentations#

Any thoughts/suggestions?
Flags: needinfo?(azasypkin)
(In reply to Manuela Muntean [:Manuela] [QA] from comment #8)
> This issue is still reproducible with latest Nightly on Win 8 64-bit with
> http://www.google.com/maps/about/explore/ but it's fixed for
> http://www.haikudeck.com/p/IXPQ9thNi1/10-tips-to-transform-your-
> presentations#
> 
> Any thoughts/suggestions?

I see that gMaps actually changes url not just url fragment. Not sure whether we can do anything with it, but I'll check.
Flags: needinfo?(azasypkin)
Yes, looks like we can handle google maps case also. Manuela, can you please file separate bug for handling URL change via pushState/popState/replaceState?
Blocks: 976020
(In reply to Oleg Zasypkin [:azasypkin] from comment #10)
> Yes, looks like we can handle google maps case also. Manuela, can you please
> file separate bug for handling URL change via
> pushState/popState/replaceState?

I've logged bug 976020, so I'm marking this as verified based on comment 8.
Status: RESOLVED → VERIFIED
Also verified with latest Aurora on Win 8 64-bit using http://www.haikudeck.com/p/IXPQ9thNi1/10-tips-to-transform-your-presentations#
You need to log in before you can comment on or make changes to this bug.