Test server www-dev.allizom.org is displaying outdate content

RESOLVED FIXED

Status

www.mozilla.org
Bedrock
--
major
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: flod, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Polish content was updated a couple of days ago in r123718.

Right now https://www-dev.allizom.org/pl is still displaying the Addons 2013 tile in English (also the string in http://www-dev.allizom.org/pl/about is not localized, so it's not just the home page).

Both stage and prod work fine with the same files, so I think it's just the cache system stuck.
https://www.allizom.org/pl/
https://www.mozilla.org/pl/
(Reporter)

Comment 1

4 years ago
Is happening again right now for Turkish.

Lang file was updated in r123845 (over 5 hours ago), test server is still displaying untranslated content
https://www-dev.allizom.org/tr/

Updated

4 years ago
Duplicate of this bug: 958047
Setting as major, this has been broken for a week now and this is impacting l10n work on mozilla.org seriously as localizers can't check their work on a staging server anymore.
Severity: normal → major
Component: General → Bedrock

Comment 4

4 years ago
Can you help see what the problem is here?
Flags: needinfo?(cturra)
i think i know what's going on here! back in bug 952132 i added a check if the current version deployed was the most recent in the repo and if so, not continue pushing the code. this appears to affect the locale push also. let me look into this so the locale push still happen. in the mean time, i have manually pushed this for you.
Flags: needinfo?(cturra)
this should now be sorted, i moved the www-dev locale update script to it's own cron job so it's now decoupled from the code pushes similar to stage and prod.
(Reporter)

Comment 7

4 years ago
https://www-dev.allizom.org/is/

Text was updated less than 30 minutes ago in r123925 (translated MDN tile), so if you haven't cleared the cache manually I guess it's working.
Looks like it's working.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.