Closed Bug 956781 Opened 7 years ago Closed 6 years ago

Meetup page causes fullpage invalidation while scrolling, with background-image & "background-attachment: fixed"

Categories

(Core :: Layout, defect, P4)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1039020

People

(Reporter: BenWa, Unassigned)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

Priority: -- → P4
Summary: Page causes fullpage invalidation while scrolling → Meetup page causes fullpage invalidation while scrolling
I can reproduce this on 64-bit Linux nightly.

It only happens *after* the background image has loaded (which takes a few seconds, on my internet connection at home). Before that image has appeared, the page only invalidates thin stripes at the edges when I scroll, as I'd expect.
Summary: Meetup page causes fullpage invalidation while scrolling → Meetup page causes fullpage invalidation while scrolling, after background image has loaded
OS: Mac OS X → All
Hardware: x86 → All
Version: unspecified → Trunk
Here's a reduced testcase.

Basically, when you have a container-div with "background-attachment:fixed", we seem to think that all of its children need to be repainted on scroll.

We probably *would* need to repaint (or at least recomposite) if those children were something like text with a transparent background, because then the text would be moving to be over a different part of the image, and it'd need to be recomposited over that image.

But in this case, there child is one big opaque background (with text inside of it), so there's no reason it'd all need to be repainted when it's scrolled.
s/there child/the child/
Attachment #8356399 - Attachment description: reduced testcase 1 → reduced testcase 1 (turn on paint flashing & scroll)
Summary: Meetup page causes fullpage invalidation while scrolling, after background image has loaded → Meetup page causes fullpage invalidation while scrolling, with background-image & "background-attachment: fixed"
This was fixed in bug 1039020.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1039020
You need to log in before you can comment on or make changes to this bug.