Closed Bug 956882 Opened 6 years ago Closed 6 years ago

Enable connect page by default

Categories

(DevTools :: Framework, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 942756

People

(Reporter: dcamp, Unassigned)

References

(Blocks 1 open bug)

Details

Connect page isn't the best experience, but it isn't made any better by needing to toggle a pref and restart.  Until we have a better experience, should we just turn on Connect by default?
I think bug 956881 is a better solution, agree? If so, we can close / dup this?
I don't really agree - Connect isn't a great experience, but it's a fairly core part of our offering.  Having it hidden behind a busywork pref doesn't seem useful to me.
(In reply to Dave Camp (:dcamp) from comment #2)
> I don't really agree - Connect isn't a great experience, but it's a fairly
> core part of our offering.  Having it hidden behind a busywork pref doesn't
> seem useful to me.

Well we have the checkbox in the options panel, and I am totally down for enabling devtools.debugger.remote-enabled by default, but I think that it sucks that we require a restart just to show/hide the menu item.
Aaaaaaand I just checked and we do show/hide the connect menu item without a restart when you check/uncheck the enable remote debugging option.

Why do we require restart again?
In bug 942756, we will enable the connect page by default (and change the meaning of devtools.debugger.remote-enabled). Also, we will merge the connection screen in the App Manager (bug 912900).
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 942756
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.