[B2G] Opening mutiple application causes the device to lose functionality

RESOLVED DUPLICATE of bug 952170

Status

RESOLVED DUPLICATE of bug 952170
5 years ago
5 years ago

People

(Reporter: selkabule, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.2 unaffected, b2g-v1.3 affected)

Details

(Whiteboard: dogfood1.3)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8356264 [details]
Salem log 1.txt

Description:
After downloading multiple applications from the market place and opening them, causes the device to lose functionality 

Repro Steps:
1) Updated to Buri1.3 
2) Open the Marketplace application
3) Download multiple application "Jocly kids, connectA2, Loqui im, soundcloud, Twitter, message me, Pasjians/solitaire, Wallpaper wondeful, Wikipedis, aircombat, interactive firefox logo, pulse, Calculator" 
4)Open the applications one after another

Actual:
The device looses functionality and the user is unable to interact with the device until restarting 

Expected:
The user can open multiple applications and be able to transfer to any application with no loose of functionality of the device

Environmental Variables
Device: buri1.3 Moz Ril
Build ID: 20140106004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/a43cb4b322d3
Gaia: 35a60b82f8cf2d759939a350e2dadbb9d8b2f5dc
Platform Version: 28.0a2


Notes:
Repro frequency: 100%, 
See attached: logcat
Salem - this bug is a bit vague. What do you mean by lose functionality?
Flags: needinfo?(selkabule)
(Reporter)

Comment 2

5 years ago
Hi Jason, 
The device well go into a blink screen and there will be limited interaction with the device, like by locking the screen and try to unlock by swiping the lock key the device well not open. The user is blocked and unable to inter to the main page or to any function in the phone. The only way to make the device function is to restart it.
Flags: needinfo?(selkabule)
Does this reproduce on 1.2?
Keywords: qawanted
(Reporter)

Comment 4

5 years ago
This issue does not reproduce on buri1.2

Environmental Variables
Device: buri1.2 Moz Ril
Build ID: 20140106004001
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/d552c08a72d0
Gaia: 8441587c3b352e052fee07665c21fd192540f19f
Platform Version: 26.0

The device well function normal without any loss of functionality or blocking the user to use the device
status-b2g-v1.2: --- → unaffected
Keywords: qawanted → regression
blocking-b2g: --- → 1.3?
Component: Gaia::System::Lockscreen → Gaia::System
Keywords: regressionwindow-wanted
(Reporter)

Comment 5

5 years ago
I found an easier way to repo this issue:
1. Download Poppit from the marketplace  
2. Tap the application twice 
3. observe the application launches into a blank screen
4. lock the the screen 
5. observe the user cannot unlock the device

Environmental Variables
Device: Buri 1.3 MoZ Ril 
Build ID: 20140107004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/71ad7ff30010
Gaia: ff5f06dd321f7d2bf4a5b311ded2c56e865d4f83
Platform Version: 28.0a2
I've worked with Salem on this bug and it turned out that the behavior observed here is caused by a OS crash. It's a same crash that we are seeing all over the place now...
https://crash-stats.mozilla.com/report/index/97d6c85f-f8a9-459c-ba55-627fb2140107

I am duping this bug to bug 952170 where we track this crash
Status: NEW → RESOLVED
blocking-b2g: 1.3? → ---
Last Resolved: 5 years ago
Keywords: regression, regressionwindow-wanted
Resolution: --- → DUPLICATE
Duplicate of bug: 952170
You need to log in before you can comment on or make changes to this bug.