Closed Bug 956982 Opened 7 years ago Closed 3 years ago

Clean up omni.ja content

Categories

(Firefox OS Graveyard :: Runtime, defect)

All
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: fabrice, Assigned: fabrice)

References

Details

(Whiteboard: [~1.8MB])

Attachments

(2 files)

The omni.ja we ship in b2g has many useless files. Let's do some cleanup, especially since we have size limitations on some platforms.
My current wip, with still a lot to be done. Currently this patch shrinks omni.ja from 5235483 bytes to 4943272 bytes.
Depends on: 957241
With this patch, the one in bug 957241 and applying chrome js minification (bug 903149) I end up with an omni.ja that is 3424073 bytes, which is 1.8MB less than without any patch.
Whiteboard: [tarako] → [tarako][~1.8MB]
Cheng, can you test this patch on tarako build?
Flags: needinfo?(cheng.luo)
I suggest this patch should be landed to v1.3 as soon as possible.
I have to merge the patch manually one by one.
the result data about omni.ja on tarako as follow:
before  5305815
after   4783942
Flags: needinfo?(cheng.luo)
blocking-b2g: --- → 1.3?
We can't take that on 1.3 either, it's fairly risky. I also need to clean it up since it's breaking b2g desktop builds.
marking blocking- as such with povb to indicate that this lands only in tarako
blocking-b2g: 1.3? → -
Whiteboard: [tarako][~1.8MB] → [tarako][~1.8MB][POVB]
triage: 1.3T+ for tarako branch only
blocking-b2g: - → 1.3T+
Whiteboard: [tarako][~1.8MB][POVB] → [~1.8MB]
(In reply to Fabrice Desré [:fabrice] from comment #5)
> We can't take that on 1.3 either, it's fairly risky. I also need to clean it
> up since it's breaking b2g desktop builds.

Blocking and fairly risky is a bad combination. I think it should either land asap or we shouldn't block on it.
Component: General → Runtime
Fabrice, wonder if this is still being worked on? or do we still need this in Tarako? Thanks
Flags: needinfo?(fabrice)
I'd like to finish that but it's a bit risky now.
Flags: needinfo?(fabrice)
This patch is very likely to be the cause of bug 982592 - I'm clearing the 1.3t nomination since it's really too risky at this point.
blocking-b2g: 1.3T+ → ---
Depends on: 1003731
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.