Closed Bug 957514 Opened 7 years ago Closed 7 years ago

[gonk-kk] FakeSurfaceComposer hit compile error

Categories

(Firefox OS Graveyard :: GonkIntegration, defect)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(Not tracked)

RESOLVED FIXED
1.3 C2/1.4 S2(17jan)

People

(Reporter: seinlin, Assigned: seinlin)

References

Details

Attachments

(1 file, 1 obsolete file)

In gonk-kk build, FakeSurfaceComposer hit a compile error.
Blocks: gonk-kk
Attached patch bug-957514-fix.patch (obsolete) — Splinter Review
Hi Michael, Can you help me have a look if this is reasonable?
Attachment #8357023 - Flags: review?(mwu)
Hm, don't you need to declare these new functions in FakeSurfaceComposer.h ?
Please assign bugs to yourself when appropriate.
Assignee: nobody → kli
Yes, need to declare these in FakeSurfaceComposer.h. Now, MOZ_OMX_DECODE and MOZ_B2G_CAMERA are disabled, so FakeSurfaceComposer.cpp is not compiled. The error is caused by nsAppShell.cpp. 
Do you think we need to move android::FakeSurfaceComposer::instantiate() into MOZ_OMX_DECODER condition check?
I'll remove FakeSurfaceComposer.cpp at this moment.
Attachment #8357023 - Attachment is obsolete: true
Attachment #8357023 - Flags: review?(mwu)
Attachment #8357102 - Flags: review?(mwu)
Attachment #8357102 - Flags: review?(mwu) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/acdb2a60fdaa
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
Hi,

We are getting below error due to there is no fake SurfaceFlinger.

Line 649: 09-02 18:50:52.906 I/ServiceManager(  819): Waiting for service SurfaceFlinger...
                Line 797: 09-02 18:50:53.906 I/ServiceManager(  819): Waiting for service SurfaceFlinger...
                Line 829: 09-02 18:50:54.906 I/ServiceManager(  819): Waiting for service SurfaceFlinger...
                Line 859: 09-02 18:50:55.906 I/ServiceManager(  819): Waiting for service SurfaceFlinger...
                Line 889: 09-02 18:50:56.906 I/ServiceManager(  819): Waiting for service SurfaceFlinger...

Can any body suggest?
You need to log in before you can comment on or make changes to this bug.