Closed Bug 957613 Opened 6 years ago Closed 6 years ago

[B2G][v1.3][Marketplace] Test Marketplace app without internet connectivity message

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+, b2g-v1.3 fixed)

RESOLVED FIXED
1.3 C2/1.4 S2(17jan)
blocking-b2g 1.3+
Tracking Status
b2g-v1.3 --- fixed

People

(Reporter: AndreiH, Assigned: aus)

References

Details

(Keywords: regression, Whiteboard: [systemsfe][qa-])

Attachments

(1 file)

Attached image 2014-01-08-16-15-36.png
STR:

1. Install Marketplace dev from: https://marketplace-dev.allizom.org/manifest.webapp
2. Disable any internet connectivity.
3. Open Marketplace dev app.
4. Inspect the message shown.

Expected Results:
Message: "Marketplace Dev requires a network connection. Try connecting to a Wi-Fi or mobile data network."

Actual Results:
The warning screen shown is in the attachment.

I am currently testing on Hamachi device build v1.3:
Gaia      522779225e86b7a4d1bf759036678dc321a1486e                           
Gecko     http://hg.mozilla.org/releases/mozilla-aurora/rev/2287f2839256     
BuildID   20140108004001                                                     
Version   28.0a2
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
Our offline page is https://bug875734.bugzilla.mozilla.org/attachment.cgi?id=753948

This looks like a gaia page so pushing over to Firefox OS.
Product: Marketplace → Firefox OS
Version: 1.0 → unspecified
This looks like a bug with the new offline error page.
Blocks: 882186
blocking-b2g: --- → 1.3?
Component: General → Gaia::System::Window Mgmt
Keywords: regression
Whiteboard: [systemsfe]
Depends on: 957733
Assignee: nobody → aus
Status: NEW → ASSIGNED
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
This should be fixed now too thanks to bug 957733 landing.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
blocking-b2g: 1.3? → 1.3+
Whiteboard: [systemsfe] → [systemsfe][qa-]
You need to log in before you can comment on or make changes to this bug.