Closed Bug 957702 Opened 6 years ago Closed 6 years ago

The new browser menu is not wide enough in maximized windows

Categories

(Firefox :: Untriaged, defect)

29 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED WORKSFORME
Firefox 29

People

(Reporter: daniel.nr01, Unassigned)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [Australis:P3])

Attachments

(1 file)

Attached image screenshots.png
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140103030203

Steps to reproduce:

* Maximize the window
* Open the browser menu


Actual results:

The new (Australis) menu is not wide enough. The padding on the right side is too small compared to the left side, and in the history view half the scrollbar is hidden. See screenshot.


Expected results:

The menu should look like in restored windows.
I can't reproduce this anymore with Nightly 29.0a1 (2014-01-15). Don't know if it's fixed or just intermittent.
(In reply to Daniel from comment #1)
> I can't reproduce this anymore with Nightly 29.0a1 (2014-01-15). Don't know
> if it's fixed or just intermittent.

Fixed. :-)

See bug 874792.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
I still see this bug, however.. I run my win7 x64 at higher DPI 125%, so don't know if that is coming into play or not... 

Maximize the browser, and open the Menu-panel button and they scroll bar is just barely visible as shown the attached screenshots.
Nope, scrollbar is still mostly hidden behind the Menu-Panel with normal settings, 100% on Win7.
Assignee: nobody → mstange
Depends on: 874792
Target Milestone: --- → Firefox 29
(In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #4)
> Nope, scrollbar is still mostly hidden behind the Menu-Panel with normal
> settings, 100% on Win7.

Does this happen on a clean profile on latest nightly?
Flags: needinfo?(jmjeffery)
Reopening so this shows up on our radar.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: FIXED → ---
Whiteboard: [Australis:P3]
(In reply to :Gijs Kruitbosch from comment #5)
> (In reply to Jim Jeffery not reading bug-mail 1/2/11 from comment #4)
> > Nope, scrollbar is still mostly hidden behind the Menu-Panel with normal
> > settings, 100% on Win7.
> 
> Does this happen on a clean profile on latest nightly?

Yes, same on a new profile...
Flags: needinfo?(jmjeffery)
Hey Jim!

Just wondering if you're 100% sure that you're using the latest Nightly. Would you mind supplying a build revision id for the one you're using? You can get this from about:buildconfig.

You'll see "Built from X", where X is some URL. That's what we're interested in.

Thanks!

-Mike
Flags: needinfo?(jmjeffery)
Unassigning Markus because *if* this isn't fixed it's certainly not a priori his fault. :-)
Assignee: mstange → nobody
Status: REOPENED → UNCONFIRMED
Ever confirmed: false
(In reply to Mike Conley (:mconley) from comment #8)
> Hey Jim!
> 
> Just wondering if you're 100% sure that you're using the latest Nightly.
> Would you mind supplying a build revision id for the one you're using? You
> can get this from about:buildconfig.
> 
> You'll see "Built from X", where X is some URL. That's what we're interested
> in.
> 
> Thanks!
> 
> -Mike

Yes, today's Nightly built from cset: 
http://hg.mozilla.org/mozilla-central/rev/324e2cba1029
Win7 x64

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0
Flags: needinfo?(jmjeffery)
(In reply to Daniel from comment #0)
> The new (Australis) menu is not wide enough. The padding on the right side
> is too small compared to the left side
Can't reproduce in nightly 29.0a1 (2014-01-28), win 7 x64
> and in the history view half the scrollbar is hidden
can't measure the scrollbars due to bug 963480.
Jim, are you still seeing this? I still can't reproduce. :-(
Flags: needinfo?(jmjeffery)
(In reply to :Gijs Kruitbosch from comment #12)
> Jim, are you still seeing this? I still can't reproduce. :-(

NO, no idea when or how it got fixed, but I'm no longer seeing the scrollbar being cut off on the right side. 

If I were to guess, it probably got fixed up when the History-list was fixed to not extend beyond the bottom of the browser window.
Flags: needinfo?(jmjeffery)
Alright, I'll take it!
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.