Closed Bug 957759 Opened 6 years ago Closed 6 years ago

Remove experiment to test reachability of SRV records

Categories

(Core :: Networking: DNS, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla29
Tracking Status
firefox28 --- fixed
firefox29 --- fixed

People

(Reporter: u408661, Assigned: u408661)

References

Details

(Whiteboard: [qa-])

Attachments

(2 files)

+++ This bug was initially created as a clone of Bug #942317 +++

We're done with the SRV experiment, we can get rid of the code.
Attached patch patchSplinter Review
This is for m-c. The patch for m-a will be almost identical, but since it never got the null check from bug 950888, that will change the patch ever so slightly.
Attachment #8357358 - Flags: review?(mcmanus)
Comment on attachment 8357358 [details] [diff] [review]
patch

Review of attachment 8357358 [details] [diff] [review]:
-----------------------------------------------------------------

this is fine, and I support aurora uplift to fix a topcrash there.

(for documentation purposes, this was designed to actually just be removed from nightly when we were done with it and naturally expire in earlier releases, but given that it needs a bugfix to be stable on those earlier releases it makes more sense to just back it out of aurora. beta is not impacted.)
Attachment #8357358 - Flags: review?(mcmanus) → review+
Attached patch patch for auroraSplinter Review
[Approval Request Comment]
Bug caused by (feature/regressing bug #): 942317
User impact if declined: topcrash will continue (see bug 950888) without a different patch
Testing completed (on m-c, etc.): on m-c, this is purely a backout
Risk to taking this patch (and alternatives if risky): low 
String or IDL/UUID changes made by this patch: none

Version of the patch for aurora. It's effectively identical to the original patch (the original also had a simple fix for bug 950888, which makes this patch not quite text-identical), so I don't imagine Patrick's r+ will be an issue, but better safe than sorry.
Attachment #8358015 - Flags: review?(mcmanus)
Attachment #8358015 - Flags: approval-mozilla-aurora?
Comment on attachment 8358015 [details] [diff] [review]
patch for aurora

r+ based on comment
Attachment #8358015 - Flags: review?(mcmanus) → review+
https://hg.mozilla.org/mozilla-central/rev/731d86661319
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Attachment #8358015 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.