Closed Bug 957840 Opened 6 years ago Closed 6 years ago

tmall.com does not automatically redirect to m.tmall.com

Categories

(Web Compatibility :: Mobile, defect)

Other
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 804726

People

(Reporter: hsteen, Unassigned)

References

()

Details

(Whiteboard: [mobile-compat-form][serversniff][country-cn][contactready])

Site: http://tmall.com
tmall.com does not automatically redirect to m.tmall.com

:: Steps To Reproduce

Some HTTP requests demonstrating the server-side sniffing below - first Android stock, then Firefox OS:

GET / HTTP/1.1
Host: www.tmall.com
Connection: keep-alive
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
x-wap-profile: http://www.htcmms.com.tw/Android/Common/PJ461/ua-profile.xml
X-Requested-With: com.android.browser
User-Agent: Mozilla/5.0 (Linux; U; Android 4.1.1; nb-no; HTC_One_X Build/JRO03C) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Mobile Safari/534.30
Accept-Encoding: gzip,deflate
Accept-Language: nb-NO, en-US
Accept-Charset: utf-8, iso-8859-1, utf-16, *;q=0.7

HTTP/1.1 302 Found
Server: Tengine
Date: Wed, 08 Jan 2014 23:31:50 GMT
Content-Type: text/html
Content-Length: 260
Connection: keep-alive
Location: http://m.tmall.com/?sprefer=sypc01
Expires: Thu, 09 Jan 2014 23:31:50 GMT
Cache-Control: max-age=86400

------------------------------------------------------------------
GET /?sprefer=sypc01 HTTP/1.1
Host: m.tmall.com
Connection: keep-alive
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
x-wap-profile: http://www.htcmms.com.tw/Android/Common/PJ461/ua-profile.xml
X-Requested-With: com.android.browser
User-Agent: Mozilla/5.0 (Linux; U; Android 4.1.1; nb-no; HTC_One_X Build/JRO03C) AppleWebKit/534.30 (KHTML, like Gecko) Version/4.0 Mobile Safari/534.30
Accept-Encoding: gzip,deflate
Accept-Language: nb-NO, en-US
Accept-Charset: utf-8, iso-8859-1, utf-16, *;q=0.7

HTTP/1.1 200 OK
Server: Tengine
Date: Wed, 08 Jan 2014 23:31:50 GMT
Content-Type: text/html;charset=utf-8
Connection: keep-alive
Vary: Accept-Encoding
X-TB-BD: Acer
X-TB-M: A100
X-TB-OS: Android
Cache-Control: must-revalidate,no-cache
supportWebp: 
WapVersion: aXBob25l
Set-Cookie: WAPFDFDTGFG=%2B4dRjM5djSecKyo4JwyfmJ2ZUOoVjAFESROyo8XRbFU%3D; Domain=.m.tmall.com; Expires=Thu, 08-Jan-2015 23:31:50 GMT; Path=/
abtest: b515
Set-Cookie: imewweoriw=1hNcJ89mLnTYF6hE9V0Q6A%3D%3D; Domain=.m.tmall.com; Expires=Thu, 09-Jan-2014 23:31:50 GMT; Path=/
TBTrack-Id: du=854d2da140fc684f
Content-Language: zh-CN
Content-Length: 34816

------------------------------------------------------------------
GET / HTTP/1.1
Host: www.tmall.com
User-Agent: Mozilla/5.0 (Mobile; rv:27.0) Gecko/27.0 Firefox/27.0

HTTP/1.1 200 OK
Server: Tengine
Date: Wed, 08 Jan 2014 23:33:14 GMT
Content-Type: text/html; charset=GB2312
Connection: keep-alive
Vary: Accept-Encoding
Expires: Wed, 08 Jan 2014 23:33:14 GMT
Cache-Control: max-age=0
Set-Cookie: mall_fp_ab=2012b; expires=Tue, 28-Jan-2014 23:33:14 GMT; path=/; domain=.tmall.com
Content-Length: 54296

------------------------------------------------------------------


:: Expected Result

prettiness

:: Actual Result

basic site

:: Additional Information

Software Version: 1.1
Reporter's User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [mobile-compat-form] → [mobile-compat-form][serversniff][country-cn][contactready]
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 804726
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.