Startup crash when general.useragent.override major version < 5

VERIFIED DUPLICATE of bug 83376

Status

()

defect
--
critical
VERIFIED DUPLICATE of bug 83376
18 years ago
18 years ago

People

(Reporter: mozilla-bugs, Assigned: bnesse)

Tracking

({crash})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010801
BuildID:    2001080104

After setting user_pref("general.useragent.override","Mozilla/4.0 (compatible;
MSIE 5.5; Windows NT 5.0)"); in user.js, I get a startup crash with the message
"INTERNAL ERROR on Browser End: Expected a version > 5! Version = 4".  The crash
is the same regardless of what I put inside the UA parentheses.

I also get an odd "System error?:: No such file or directory" error.

Reproducible: Always
Steps to Reproduce:
1. Create <b>$HOME/.mozilla/.../user.js</b> with the following contents:
   <tt>user_pref("general.useragent.override","Mozilla/4.0 (compatible; MSIE
5.5; Windows NT 5.0)");</tt>
2. Start mozilla: <tt>/usr/local/mozilla/mozilla</tt>
3. Witness crash prior to GUI launch:
   <tt>(QFA)Talkback loaded Ok.
INTERNAL ERROR on Browser End: Expected a version > 5! Version = 4

System error?:: No such file or directory</tt>

Actual Results:  Full output of <tt>/usr/local/mozilla/mozilla</tt>:

<tt>/usr/local/mozilla/run-mozilla.sh /usr/local/mozilla/mozilla-bin
MOZILLA_FIVE_HOME=/usr/local/mozilla
  LD_LIBRARY_PATH=/usr/local/mozilla:/usr/local/mozilla/plugins
     LIBRARY_PATH=/usr/local/mozilla:/usr/local/mozilla/components
       SHLIB_PATH=/usr/local/mozilla
          LIBPATH=/usr/local/mozilla
       ADDON_PATH=/usr/local/mozilla
      MOZ_PROGRAM=/usr/local/mozilla/mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
 I am inside the initialize
 Hey : You are in QFA Startup 
(QFA)Talkback loaded Ok.
INTERNAL ERROR on Browser End: Expected a version > 5! Version = 4

System error?:: No such file or directory
</tt>


Expected Results:  Mozilla should start up normally and properly spoof User-Agent.

No talkback output.

Comment 1

18 years ago
I can confirm this. It happened to me too.

Comment 2

18 years ago
Confirming as per Pratik's comments.
URL: N/A
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash
dupe of bug 83376
(BTW: this one is very easy to find)

*** This bug has been marked as a duplicate of 83376 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED

Comment 5

18 years ago
I don't think this is a dupe of bug 83376. (In fact I don't think 83376 is 100%
reproducible but I'll comment on that in that bug).

I set my UA to

user_pref("general.useragent.override", "Mozilla/4.0 (compatible;)");

and it crashed with msg

INTERNAL ERROR on Browser End: Expected a version > 5! Version = 4

System error?:: No such file or directory

Now this was on NS6.1 but its crashed on 15th Aug nightly too. Reason I didn't
try on today's nightly is bcos it seems todays nightly is broken.

In NS6.1 again, if I set my UA string to

user_pref("general.useragent.override", "Mozilla/5.0 (compatible; MSIE5.5;
Windows 98;");

it works!

Also if you look at teh error message generated, its different.

Comment 6

18 years ago
Sorry abt the earlier message. I reread the bug properly and I had
misunderstood. I think its a dupe.
(Reporter)

Comment 7

18 years ago
No.  This bug is not a dupe of 83376.

Matti, I did come across 83376 in a diligent search before opening this bug, as
I found it difficult to believe that nobody had ever encountered this behavior
before.  However, if you re-read both bugs carefully, you will see that they are
only tenuously related.

83376 deals with Sun's Java plugin refusing to start up with the UA string set
to spoof IE.  This bug (95786) does not concern the JRE, and is reproducible
even when the UA string is set to spoof older versions of Netscape.

Reopening.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
mozilla-bugs@counterintuitive.org: 
bug 83376 is about to change the UA string in general to a different version and 
JRE displays an error message and mozilla is crashing.

Do you see this crash/bug if you deinstall Java ?
Marking as a dupe again - please reopen only if you see this crash without 
installed Java plugin.
See also one of the dupes of bug 83376 -> bug 92775
The version number in the UA is the problem (Mozilla/4.0, Mozilla/4.75...,only 
Mozilla/5.0 and above works)
That is clear if you read your error message.... (Expected a version > 5! 
Version = 4)

*** This bug has been marked as a duplicate of 83376 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 9

18 years ago
Matti, I stand corrected.  Removing the symlink to the OJI plugin from the
$MOZILLA_HOME/plugins directory stopped the crash.  Also, running the plugin
through strings gets the error messages from my report.

Perhaps having plugins announce their identity when talking on stdout/stderr
would help in debugging?  Woulda stopped me making an ass of myself =]

-jeff
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.