Support gonk-kk build in gecko

RESOLVED FIXED in 1.3 C2/1.4 S2(17jan)

Status

defect
--
critical
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: seinlin, Assigned: seinlin)

Tracking

unspecified
1.3 C2/1.4 S2(17jan)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Support gonk-kk build in gecko.
Posted patch bug-957892.patch (obsolete) — Splinter Review
Now only NFC module is enabled for gonk-kk. For BT, Camera and others need to be enabled when related bug got fixed.
Assignee: nobody → kli
Status: NEW → ASSIGNED
Attachment #8357520 - Flags: review?(mwu)
Blocks: gonk-kk
Comment on attachment 8357520 [details] [diff] [review]
bug-957892.patch

Review of attachment 8357520 [details] [diff] [review]:
-----------------------------------------------------------------

::: configure.in
@@ +246,5 @@
>          MOZ_OMX_DECODER=1
>          AC_SUBST(MOZ_OMX_DECODER)
>          ;;
> +    19)
> +        GONK_INCLUDES="-I$gonkdir/frameworks/native/include -I$gonkdir/frameworks/av/include -I$gonkdir/frameworks/av/include/media -I$gonkdir/frameworks/av/include/camera -I$gonkdir/frameworks/native/include/media/openmax -I$gonkdir/frameworks/av/media/libstagefright/include"

Can you cut this include list down to just -I$gonkdir/frameworks/native/include ? This big global include list was a bit of a hack and we should try to minimize it when updating. I checked locally and it seems to work.
Hi, Michael, I try it does work. New patch is updated.
Attachment #8357520 - Attachment is obsolete: true
Attachment #8357520 - Flags: review?(mwu)
Attachment #8357616 - Flags: review?(mwu)
Comment on attachment 8357616 [details] [diff] [review]
bug-9957892-fix.patch

Let's check this in when everything else is landed.
Attachment #8357616 - Flags: review?(mwu) → review+
Duplicate of this bug: 959074
https://hg.mozilla.org/mozilla-central/rev/1f9a100bf649
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.3 C2/1.4 S2(17jan)
You need to log in before you can comment on or make changes to this bug.