Closed Bug 958106 Opened 7 years ago Closed 2 years ago

Different spacing on start and end of URL bar

Categories

(Firefox :: Theme, defect)

All
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: Mathnerd314, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Australis:P5])

Attachments

(1 file)

https://hg.mozilla.org/mozilla-central/rev/fc79651935e7 (Bug 880399) removed the star button and its CSS:
--- a/browser/base/content/browser.xul
+++ b/browser/base/content/browser.xul
...
-              <image id="star-button"
-                     class="urlbar-icon"
-                     onclick="BookmarkingUI.onCommand(event);"/>
...

https://hg.mozilla.org/mozilla-central/rev/09fd1ae57a2e (Bug 755598) added the element back, but not any of its CSS:
--- a/browser/base/content/browser.xul
+++ b/browser/base/content/browser.xul
...
+                <image id="star-button"
+                       class="urlbar-icon"
+                       onclick="BookmarkingUI.onCommand(event);"/>
...

This results in an extra 6-pixel space in the URL bar (red in the screenshot).

There is also a 3px right margin on the URL textbox (yellow in screenshot), inherited from textbox-input-box.

This bug proposes to remove/hide the star-button element and to override the 3px textbox margin to a 1px margin, so that there are 4 white pixels between the URL and the dropdown marker in the location bar (4 is chosen because it is the number of pixels between the text and the search button in the search bar).
Mike, does this make sense?
Flags: needinfo?(mdeboer)
Whiteboard: [Australis:P4]
(In reply to :Gijs Kruitbosch from comment #1)
> Mike, does this make sense?

Not right away, but I need more time to try & investigate. Leaving flag and status the same for now.
Flags: needinfo?(mdeboer)
Flags: needinfo?(mdeboer)
(In reply to Allan Gardner (:Mathnerd314) from comment #0)
> 4 is chosen because it is the number of pixels between the text and the search button in the search
> bar).
So, there are:
- 4 pixels between the beginning of the location bar and the globe
- 4 pixels between the globe and the text
- 6 pixels between the text and the dropdown arrow
- 6 pixels between the dropdown arrow and the reload button
- 6 pixels between the reload button and the edge of the location bar
- 4 pixels between the beginning of the searchbox and the google icon
- 3 pixels between the google icon and the dropdown arrow
- 5 pixels between the dropdown arrow and the text in the searchbox
- 4 pixels between the text and the search button
- 5 pixels between the search button and the edge of the searchbox
Status: UNCONFIRMED → NEW
Ever confirmed: true
Paul, thanks for taking the time to check this! I'll take a look at this patch asap.
(In reply to Paul Silaghi, QA [:pauly] from comment #3)
> (In reply to Allan Gardner (:Mathnerd314) from comment #0)
> > 4 is chosen because it is the number of pixels between the text and the search button in the search
> > bar).
> So, there are:
> a. 4 pixels between the beginning of the location bar and the globe
> b. 4 pixels between the globe and the text
> c. 6 pixels between the text and the dropdown arrow
> d. 6 pixels between the dropdown arrow and the reload button
> e. 6 pixels between the reload button and the edge of the location bar
> f. 4 pixels between the beginning of the searchbox and the google icon
> g. 3 pixels between the google icon and the dropdown arrow
> h. 5 pixels between the dropdown arrow and the text in the searchbox
> i. 4 pixels between the text and the search button
> j. 5 pixels between the search button and the edge of the searchbox

Those values are correct for FF w/out Australis. In Nightly, however, there are 12 pixels between the text and the dropdown arrow (c above) in certain cases. For example, load http://www.█████████████████████████████████████████████████████████████████████████████████████████████████████████████████.com/ and count the pixels. Edit the url and it jumps back to 6px.

This bug was primarily for the latter 12px case, but the pixel counts could also be changed.
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(mdeboer)
Resolution: --- → DUPLICATE
Duplicate of bug: 974229
I don't think this is a duplicate of bug 974229; even with that fixed, there is still the variation in spacing described in Comment 3. The mockups I could find all used identical spacing between the beginning of the URL bar, the globe, the text, whatever came after the text, and the end of the URL bar:

http://people.mozilla.org/~shorlander/files/australis-designSpecs/australis-designSpecs-windows7-mainWindow.html has a=b=c=e=4, d=8, f=h=i=j=6, and g=2
http://people.mozilla.org/~shorlander/files/australis-design-specs/australis-design-specs-osx.html has a=b=e=f=h=6, and g=2.
https://wiki.mozilla.org/images/1/17/Firefox-4-Mockup-i06-%28Win7%29-%28Aero%29-%28TabsTop%29.png has 
a=b=d=e=6, f=h=5, and g=2.

The current behavior has a=b=4 and c=d=e=6, which is not consistent at all.
Status: RESOLVED → REOPENED
Flags: needinfo?(mdeboer)
Resolution: DUPLICATE → ---
(In reply to Allan Gardner (:Mathnerd314) from comment #7)
> I don't think this is a duplicate of bug 974229; even with that fixed, there
> is still the variation in spacing described in Comment 3. The mockups I
> could find all used identical spacing between the beginning of the URL bar,
> the globe, the text, whatever came after the text, and the end of the URL
> bar:
> 
> http://people.mozilla.org/~shorlander/files/australis-designSpecs/australis-
> designSpecs-windows7-mainWindow.html has a=b=c=e=4, d=8, f=h=i=j=6, and g=2
> http://people.mozilla.org/~shorlander/files/australis-design-specs/australis-
> design-specs-osx.html has a=b=e=f=h=6, and g=2.
> https://wiki.mozilla.org/images/1/17/Firefox-4-Mockup-i06-%28Win7%29-
> %28Aero%29-%28TabsTop%29.png has 
> a=b=d=e=6, f=h=5, and g=2.
> 
> The current behavior has a=b=4 and c=d=e=6, which is not consistent at all.

I'm confused. AIUI, comment #3 is now correct also for Australis. That means there is no longer an issue as compared to pre-Australis, correct? It's just that you would like these values to be more internally consistent than they are.

I don't think that's something we should worry about for now.
Flags: needinfo?(mdeboer)
Summary: Extra space between URL and dropdown marker in location bar → Different spacing on start and end of URL bar
Whiteboard: [Australis:P4] → [Australis:P5]
Closing as this isn't a problem in the Quantum theme
Status: REOPENED → RESOLVED
Closed: 7 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.