Closed Bug 958161 Opened 6 years ago Closed 6 years ago

need a way to jump to top of message list

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 989810

People

(Reporter: dietrich, Assigned: harly)

References

Details

(Keywords: feature)

because when new messages come in, they're pushed out above viewport, so then i have to scroll and scroll and scroll to get back to the top and see new messages.

a non-discoverable but common approach is to touch the header to jump to top.
Keywords: feature
Also, if you tap the blue bar thing that mentions the existence of new messages, that scrolls you to the top.
Hm, that notification bar only is visible for a few seconds.

Most of the time, this happens to me after I pick up and unlock the phone, long after that notification is gone.
For the record, I would also love a similar feature throughout FxOS. Any time I'm deep in scrollable content, it would be great if there was a fast way back to the top.
Stephany, need UX feedback on Email specifically, but also on a system-wide convention for this common user scenario.
Flags: needinfo?(firefoxos-ux-bugzilla)
Flagging Rob on notifications.
Flags: needinfo?(rmacdonald)
Flags: needinfo?(firefoxos-ux-bugzilla)
Adding Harly for the email perspective as well. Harly, we can discuss ideas after you're back from holiday. And perhaps this is something that could be included in the patterns doc?
Flags: needinfo?(hhsu)
Sure thing Rob, I think it is good to have a global method to scroll to top of list. We will discuss it and maybe have a brainstorming workshop to think of something different from the iOS method.
Flags: needinfo?(hhsu)
This came up again elsewhere.  Assigning to Harly so we have tracking of what the next step for this bug is blocked on.  Clearing Rob's NI since he responded and this isn't really a notifications thing, that was just the only user affordance in e-mail right now that's remotely close.

One relevant change going on is that we are planning to work bug 796474 to fix infinite scrolling for e-mail.  Once that is implemented and lands, it should be possible for users to grab the scroll thumb and just drag it all the way to the top of the mail list.  I'm not sure users know that the scroll-thumbs are interactive, but it is probably more (happily) discoverable than clicking on the folder name.
Assignee: nobody → hhsu
Status: NEW → ASSIGNED
Flags: needinfo?(rmacdonald)
This is accounted for in the Building Blocks backlog. We will design the pattern and then request that a developer (likely from the Productivity team) will likely implement it. This bug will be tackled as part of the work for 1.5/2.0 and, while Harly will work on the design pattern, Harly will not implement the change.
Going to close this as a dupe in favor of bug 989810, which has some design docs attached to it, even though this one was file first. If this bug is desired to be used by another group besides productivity to track a general feature for this, then it may make sense to reopen and placed under a different component.
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 989810
You need to log in before you can comment on or make changes to this bug.