If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G][Browser] Deactivating the browser in landscape mode causes the browser screen to cut off

RESOLVED FIXED in Firefox OS v1.3

Status

Firefox OS
Gaia::System::Window Mgmt
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Salem Elkabule, Assigned: GaryChen)

Tracking

({regression})

unspecified
1.3 C3/1.4 S3(31jan)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:1.3+, b2g-v1.2 unaffected, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 unaffected)

Details

(Whiteboard: dogfood1.3)

Attachments

(2 attachments, 2 obsolete attachments)

(Reporter)

Description

4 years ago
Created attachment 8357934 [details]
Browser cut off log cat.txt

Description:
When launching the browser and navigating to a valid website. Rotating the screen to be on landscape mode and deactivating the browser or pressing the home button, but when returning to the browser through the task manger and selecting the browser. The browser application will display cut off

Repro Steps:
1) Updated Buri 1.3 
2) Launch the browser
3) Navigate to Myspace.com or any other website
4) Rotate the screen to be in landscape mode
5) Deactivate the application or press the home button
6) Hold the home button to access the task manger
7) Select the browser 
Actual:
The bottom of the browser application is cut off with a black screen

Expected:
The browser should show in full without any cutting of in the page

Environmental Variables
Device: buri 1.3 Moz Ril 
Build ID: 20140107004001
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/71ad7ff30010
Gaia: ff5f06dd321f7d2bf4a5b311ded2c56e865d4f83
Platform Version: 28.0a2

Repro frequency: 100%
See attached: video clip(http://www.youtube.com/watch?edit=vd&v=IPMrhmKU9_I), logcat
(Reporter)

Comment 1

4 years ago
This issue is not reproducible on buri 1.2

Environmental Variables:
Device: Buri 1.2 MOZ
BuildID: 20140108004002
Gaia: 539a25e1887b902b8b25038c547048e691bd97f6
Gecko: 0d8b879ffd70
Version: 26.0
Firmware Version: 20131115
QA Contact: rkunkel
This looks like a bug with orientation management in the system app.
blocking-b2g: --- → 1.3?
Component: Gaia::Browser → Gaia::System::Window Mgmt
The window occurs between the Buri v1.3 builds from 12/5 and 12/6.

- Last Working -

Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20131205040201
Gaia: 1dd0e5c644b4c677a4e8fa02e50d52136db489d9
Gecko: 725c36b5de1a
Version: 28.0a1
Firmware Version: 20131115

- First Broken -

Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20131206040203
Gaia: 8fca2ca67e8a6022fe6ed8cb576e5d59dfb5237f
Gecko: 1401e4b394ad
Version: 28.0a1
Firmware Version: 20131115
Keywords: regressionwindow-wanted
Triage: window management regression.

Alive, could you take a look?
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(alive)
Assignee: nobody → alive
Flags: needinfo?(alive)

Comment 5

4 years ago
steal it
Assignee: alive → gasolin

Comment 6

4 years ago
can reproduce only on 1.3

Updated

4 years ago
status-b2g-v1.4: --- → unaffected
steal it.
Assignee: gasolin → gchen
Created attachment 8361478 [details] [review]
pull request: https://github.com/mozilla-b2g/gaia/pull/15441

Hi Alive,
   The root cause is KM missing to listen |appwillcolse| event in v1.3 by cherry-pick bug 937487.
   
   please help to review this patch, thanks.
Attachment #8361478 - Flags: review?(alive)
Component: Gaia::System::Window Mgmt → Gaia::System::Input Mgmt
The original STR doesn't involve keyboard, are you sure this would fix defect of comment 0?
Comment on attachment 8361478 [details] [review]
pull request: https://github.com/mozilla-b2g/gaia/pull/15441

remove review flag.
Attachment #8361478 - Flags: review?(alive)
Created attachment 8361779 [details] [review]
pull request: https://github.com/mozilla-b2g/gaia/pull/15471

Hi Alive,
   Not sure is this a correct solution.
   Please help to review this patch and give me some feedback.

   Thanks.
Attachment #8361478 - Attachment is obsolete: true
Attachment #8361779 - Flags: review?(alive)
Component: Gaia::System::Input Mgmt → Gaia::System::Window Mgmt
Comment on attachment 8361779 [details] [review]
pull request: https://github.com/mozilla-b2g/gaia/pull/15471

This may or may not fix the issue, because the size when closeWindow may not fit the sizing when openWindow.

Please modify AppWindow.prototype.resize to convey the resize call in openWindow.

See v1.4 for reference.

Come to me if you have problems. Thanks.
Attachment #8361779 - Flags: review?(alive)
Created attachment 8362411 [details] [review]
pull request: https://github.com/mozilla-b2g/gaia/pull/15515

Hi Alive,
   Please help to review this patch, thanks.
Attachment #8361779 - Attachment is obsolete: true
Attachment #8362411 - Flags: review?(alive)
Attachment #8362411 - Flags: review?(alive) → review+
travis passed:
https://travis-ci.org/mozilla-b2g/gaia/builds/17262269

patch landed in v1.3:
https://github.com/mpizza/gaia/commit/73b74cdde2cacd2299e2a5ff624dac2c1520e54f
Status: NEW → RESOLVED
Last Resolved: 4 years ago
status-b2g-v1.3: affected → fixed
Resolution: --- → FIXED

Updated

4 years ago
Depends on: 984127
status-b2g-v1.3T: --- → fixed
Target Milestone: --- → 1.3 C3/1.4 S3(31jan)
You need to log in before you can comment on or make changes to this bug.