[IARC] exclude apps only in germany that get a USK Rating Refused rating

VERIFIED FIXED in 2014-02-18

Status

P4
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: kngo, Assigned: kngo)

Tracking

2014-02-18
x86
Mac OS X
Points:
---

Details

(Whiteboard: [incorrect_implementation])

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
STR:

1. App gets a USK Refused Rating
2. The system automatically excludes the app from Germany.
3. A reviewer reviews it as normal
4. The developer receives new content ratings that removes the USK Refused Rating.
5. Either the app goes into re-review or the system automatically re-enables the app for Germany.

Expected:

App excluded from Germany.

Actual:

App not excluded from Germany.
(Assignee)

Updated

5 years ago
Blocks: 929812
Priority: -- → P4
Target Milestone: --- → 2014-01-21
(Assignee)

Updated

5 years ago
Assignee: nobody → kngo
(Assignee)

Comment 1

5 years ago
https://github.com/mozilla/zamboni/pull/1655
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: 2014-01-21 → 2014-01-28
(Assignee)

Comment 2

5 years ago
Modifying the STR:

3.5 The app is not listed in Germany.
5. The system automatically re-enables the app to be listed in Germany.

Comment 3

5 years ago
Kevin, I submitted and approved an app with USK Refused Rating (https://marketplace-dev.allizom.org/app/test-app-uskref?src=search) , but I am able to find it with region set to Germany.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 4

5 years ago
https://github.com/mozilla/zamboni/pull/1747
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: 2014-01-28 → 2014-02-18

Comment 5

5 years ago
I am still able to find the app with region set to Germany : http://screencast.com/t/deFYlN6s
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 6

5 years ago
I cleared my localStorage first and then went to https://marketplace-dev.allizom.org/app/test-app-uskref?src=search&region=de where it then correctly showed "this app is not available for your region".
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
was QA done to make sure the apps are still visible in Germany when they *do* have a rating?

Comment 8

5 years ago
I am sorry but I can consistently reproduce the scenario from comment 5.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 9

5 years ago
Created attachment 8388917 [details]
Screen Shot 2014-03-10 at 6.15.31 PM.png
(Assignee)

Comment 10

5 years ago
If the app shows up, it might be because it is cached in localStorage or the request itself was cached.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED

Comment 11

5 years ago
(In reply to Kevin Ngo [:ngoke] from comment #10)
> If the app shows up, it might be because it is cached in localStorage or the
> request itself was cached.

The problem is that I was logged in with an user with admin rights and also I was the developer of the app . In this case you will be able to see an USK refused rating. Is this correct Kevin?

With another user, everything worked as expected
Flags: needinfo?(kngo)
(Assignee)

Comment 12

5 years ago
Yeah, "# Owner and reviewers can see apps regardless of region".
Flags: needinfo?(kngo)

Comment 13

5 years ago
Thank you !
Verified as fixed
Status: RESOLVED → VERIFIED

Updated

5 years ago
Whiteboard: [incorrect_implementation]
You need to log in before you can comment on or make changes to this bug.