[B2G][Twitter][Settings]Sensitive media setting cannot be changed in settings menu.

RESOLVED FIXED

Status

Tech Evangelism
Preinstalled B2G Apps
P2
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Ross Kuhlman (rkuhlman@qanalydocs.com), Assigned: Jeremy Forrester)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dogfood1.3)

Attachments

(2 attachments)

Created attachment 8358068 [details]
log.txt

The settings menu of Twitter has an option to enable/disable the display of sensitive media. The default policy is to NOT display sensitive media. If the user enables sensitive media and then saves the changes to their settings, sensitive media is still disabled when the user returns to the settings page.

Repro Steps: 
1) Updated Buri to BuildID: 20140106004001
2) Launch Twitter.
3) Tap on 'Me' tab >> Gear Icon >> Settings.
4) Tap on 'Edit' button next to 'Account & Privacy'.
5) Tap on the checkbox located beneath 'Tweet Media'
6) Save changes to settings.
7) Return to settings page.

Actual:
Sensitive media remains disabled.

Expected:
User can choose to enable/disable sensitive media

Environmental Variables:
Device: Buri v1.3 Moz RIL
BuildID: 20140106004001
Gaia: 35a60b82f8cf2d759939a350e2dadbb9d8b2f5dc
Gecko: a43cb4b322d3
Version: 28.0a2
Firmware Version: 20131115

Notes:

Repro frequency: 100%
See attached: logcat.
Created attachment 8358072 [details]
TwitterSensitiveMedia.png

Updated

4 years ago
Blocks: 869205
This issue also occurs on 1.1 and 1.2

1.2 Environmental Variables:
Device: Buri 1.2 MOZ
BuildID: 20140108004002
Gaia: 539a25e1887b902b8b25038c547048e691bd97f6
Gecko: 0d8b879ffd70
Version: 26.0
Firmware Version: 20131115

1.1 Environmental Variables
Device: Buri v 1.1.0 COM RIL 
Build ID: 20140102041202
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/bdac595a4e46
Gaia: 6ff3a607f873320d00cb036fa76117f6fadd010f
Platform Version: 18.1
RIL Version: 01.01.00.019.281

Comment 3

4 years ago
Was able to reproduce on Inari 1.1

Please review and provide fix date.  Thank you
Assignee: nobody → hkirschner
Status: NEW → ASSIGNED
Priority: -- → P2
(Assignee)

Comment 4

4 years ago
Crossposted as MTWO-155

Updated

4 years ago
Assignee: hkirschner → jforrester
(Assignee)

Comment 5

4 years ago
A fix for this has been made, - let me know if you can reproduce

Comment 6

4 years ago
Unable to reproduce on Buri v1.3.  Thank you, Jeremy!

Changing status to Resolved - Fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Solved on OPENC 1.3
You need to log in before you can comment on or make changes to this bug.