Closed Bug 958400 Opened 6 years ago Closed 2 years ago

goo.ne.jp sends desktop content to Firefox OS

Categories

(Web Compatibility :: Mobile, defect, P5)

ARM
Gonk (Firefox OS)
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: karlcow, Unassigned)

References

()

Details

(Whiteboard: [mobile-compat-form] [serversniff] [country-jp] [contactready])

Attachments

(1 file)

Site: http://www.goo.ne.jp/
goo.ne.jp sends desktop content to Firefox OS

:: Steps To Reproduce

1. With Firefox OS Mobile
2. Go to http://www.goo.ne.jp/


:: Expected Result

Receive a mobile friendly content like it is happening for Safari iOS and Firefox Android

:: Actual Result

Received the Desktop Content.

:: Additional Information

Software Version: 1.2
Device Information: ZTE roamer2
Reporter's User Agent: Mozilla/5.0 (Android; Mobile; rv:25.0) Gecko/25.0 Firefox/25.0
Ready to be contacted. Ask for getting the same content than Firefox Android.
(note: there are minor display issues on the Firefox Android but nothing creating a bad user experience)


# Firefox Android
→ http -b GET http://www.goo.ne.jp/ "User-Agent: Mozilla/5.0 (Android; Mobile; rv:18.1) Gecko/18.1 Firefox/18.1" | grep -i mobile
<script src="http://img.www.goo.ne.jp/js/sp/jquery.mobile.custom.min.js"></script>


# Firefox OS
→ http -b GET http://www.goo.ne.jp/ "User-Agent: Mozilla/5.0 (Mobile; rv:18.1) Gecko/18.1 Firefox/18.1" | grep -i mobile
<div id="mobile" class="lcBox">
<a id="menu-mobile-3" href="http://www.goo.ne.jp/"><img src="http://img.www.goo.ne.jp/img/qr.gif?2" width="58" height="58" alt="QRコード" class="qr"></a>
<!--/mobile--></div>


# iOS Safari
→ http -b GET http://www.goo.ne.jp/ "User-Agent: Mozilla/5.0 (iPhone; CPU iPhone OS 5_0 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9A334 Safari/7534.4
8.3" | grep -i mobile
<a href="profile/goo.mobileconfig" data-cid="spft13-footer-3">
<script src="http://img.www.goo.ne.jp/js/sp/jquery.mobile.custom.min.js"></script>
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hardware: Other → ARM
Whiteboard: [mobile-compat-form] → [mobile-compat-form] [serversniff] [country-jp] [contactready]
Duplicate of this bug: 960407
It seems that Goo is a bit like Yahoo! with a lot of subsites.
The home page is more or less an aggregator of services.

bizex.goo.ne.jp
blog.goo.ne.jp
coupon.gourmet.goo.ne.jp
dictionary.goo.ne.jp
feature.goo.ne.jp
fortune.goo.ne.jp
health.goo.ne.jp
help.goo.ne.jp
ima.goo.ne.jp
job.goo.ne.jp
login.mail.goo.ne.jp
mail.goo.ne.jp
news.goo.ne.jp
oshiete.goo.ne.jp
play.google.com
pr.goo.ne.jp
ranking.goo.ne.jp
recipe.gourmet.goo.ne.jp
s-goo.shufoo.net
search.goo.ne.jp
sp.oshiete.goo.ne.jp
transit.goo.ne.jp
travel.goo.ne.jp
tv.goo.ne.jp
weather.goo.ne.jp
www.goo.ne.jp
etc.
Hello,
We need to contact Goo. Could you help?
Flags: needinfo?(tkosaka)
Flags: needinfo?(nshimizu)
Flags: needinfo?(mkato)
Flags: needinfo?(bugzilla)
Kosaka-san, could you handle this?
Flags: needinfo?(mkato)
Flags: needinfo?(nshimizu)
Flags: needinfo?(bugzilla)
dynamis should have a contact information, so he'll contact the company (NTT Resonant Inc.) who provide goo.ne.jp service.
Flags: needinfo?(tkosaka)
We need to contact them for Firefox OS. Given that it is working the same than Firefox Android.
Flags: needinfo?(kudo)
I'll contact Goo about this issue, when my current mission(Android Firefox issues) are finished.
Flags: needinfo?(kudo)
Priority: -- → P5
Closing as we are not working on Firefox OS anymore.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.