Closed Bug 958500 Opened 6 years ago Closed 6 years ago

Content with text-shadow drawed outside of containers with fixed height and overflow:hidden with hardware acceleration on Windows

Categories

(Core :: Graphics, defect)

29 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 953334

People

(Reporter: bdanee88, Unassigned)

References

Details

Attachments

(1 file)

Attached image render-error.png
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20140106141415

Steps to reproduce:

I have a container with fixed height and overflow set to hidden. The content inside the container has text shadow property set.

http://jsfiddle.net/Z8twG/2/
When there are more than paragraphs (one added every second), click the blue div, then click into the CSS box above.

jQuery plugins (eg. jScrollPane with autoReinitialize set to true) can reproduce this problem without any clicking.


Actual results:

Text content visible partially on screen with text-shadow is rendered outside the container without text-shadow (see attached image)

Tested with Firefox 27 Beta and the latest Nightly (downloaded on 2014-01-10) on Windows 7 64bit, both was incorrect.

If we remove the text-shadow property, it renders fine.


Expected results:

Content outside the container is not visible.
Daniel, do you see this in Firefox 26 as well?  I can't seem to reproduce on Mac nightly, so might be Windows-graphics specific....
- I tested it on some more computers (same operating systems, FF26 and FF27) and it was OK.
- Then I tried to start FF 27 in safe mode on my computer and it was also fine.
- Tried to disable all plugins without going to safe mode - the error appeared again.
- Disabled hardware acceleration in Settings - no errors again.
- The problem does not appear over RDP with hadware acceleration on (but I think hardware acceleration is not available anyway)
Dániel, thank you for testing that!
Status: UNCONFIRMED → NEW
Component: Layout: View Rendering → Graphics
Ever confirmed: true
Summary: Content with text-shadow drawed outside of containers with fixed height and overflow:hidden → Content with text-shadow drawed outside of containers with fixed height and overflow:hidden with hardware acceleration on Windows
Probably a duplicate of bug 953334 - could you verify that the bug occurs in
the latest beta debug build:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-01-10-mozilla-beta-debug/
and then again in a few days after the fix lands?  Thanks.
Depends on: 953334
Dániel, can you verify this is now fixed in the latest nightly beta builds?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-01-16-mozilla-beta-debug/
Thanks.
Flags: needinfo?(bdanee88)
I'll try the new version tomorrow on the machine the bug occured.
Flags: needinfo?(bdanee88)
The bug disappeared in the linked beta-debug version.
Great, thanks for the report and help with testing!
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: in-testsuite?
Resolution: --- → DUPLICATE
Duplicate of bug: 953334
You need to log in before you can comment on or make changes to this bug.