Couldn't correct locale. - java.lang.IllegalStateException: No ContextGetter; cannot fetch prefs.

RESOLVED DUPLICATE of bug 949495

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 949495
4 years ago
4 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

({reproducible})

Trunk
ARM
Android
reproducible
Points:
---

Firefox Tracking Flags

(firefox28 affected, firefox29 affected)

Details

(Reporter)

Description

4 years ago
D/GeckoBrowserApp(12126): BrowserApp.onTabChanged: 3: STOP
W/GeckoApplication(12231): Couldn't correct locale.
W/GeckoApplication(12231): java.lang.IllegalStateException: No ContextGetter; cannot fetch prefs.
W/GeckoApplication(12231): 	at org.mozilla.gecko.LocaleManager.getSharedPreferences(LocaleManager.java:79)
W/GeckoApplication(12231): 	at org.mozilla.gecko.LocaleManager.getPersistedLocale(LocaleManager.java:211)
W/GeckoApplication(12231): 	at org.mozilla.gecko.LocaleManager.getCurrentLocale(LocaleManager.java:160)
W/GeckoApplication(12231): 	at org.mozilla.gecko.LocaleManager.correctLocale(LocaleManager.java:89)
W/GeckoApplication(12231): 	at org.mozilla.gecko.GeckoApplication.onConfigurationChanged(GeckoApplication.java:46)
W/GeckoApplication(12231): 	at android.app.ActivityThread.performConfigurationChanged(ActivityThread.java:4456)
W/GeckoApplication(12231): 	at android.app.ActivityThread.handleConfigurationChanged(ActivityThread.java:4682)
W/GeckoApplication(12231): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1677)
W/GeckoApplication(12231): 	at android.os.Handler.dispatchMessage(Handler.java:102)
W/GeckoApplication(12231): 	at android.os.Looper.loop(Looper.java:158)
W/GeckoApplication(12231): 	at android.app.ActivityThread.main(ActivityThread.java:5851)
W/GeckoApplication(12231): 	at java.lang.reflect.Method.invokeNative(Native Method)
W/GeckoApplication(12231): 	at java.lang.reflect.Method.invoke(Method.java:515)
W/GeckoApplication(12231): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:1067)
W/GeckoApplication(12231): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:883)
W/GeckoApplication(12231): 	at dalvik.system.NativeStart.main(Native Method)
W/GeckoApplication(12231): Caused by: java.lang.RuntimeException: No prefs.
W/GeckoApplication(12231): 	... 16 more

This happens on device orientation rotation.

This is the same as bug 945832. I mentioned on Dec 12th that I would open a new bug but I can not find it, not sure if I did.

--
HTC One (Android 4.4)
Aurora (01/10)
Nightly (01/10)
(Reporter)

Comment 1

4 years ago
Still see this, all devices, happens on rotation.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 949495
You need to log in before you can comment on or make changes to this bug.