Closed Bug 958703 Opened 6 years ago Closed 6 years ago

Turn off Firefox desktop builds for select locales

Categories

(Firefox Build System :: General, defect)

27 Branch
defect
Not set

Tracking

(firefox27+ verified, firefox28+ verified)

VERIFIED FIXED
mozilla29
Tracking Status
firefox27 + verified
firefox28 + verified

People

(Reporter: gueroJeff, Assigned: Pike)

References

Details

Attachments

(3 files)

The following localization efforts have dissolved long ago and there are very few, if any, of their users on Firefox desktop. We'd like to turn off their builds until a new effort comes to take over the localization.

- [ta-LK] Tamil, Sri Lanka (all three branches)
- [ak] Akan (Aurora, Beta)
- [lg] Luganda (Aurora, Beta)
- [nso] Northern Sotho (Aurora)
- [sah] Sakha (Aurora)
- [wo] Wolof (Aurora)

We'll want to remove these from all-locales and shipped-locales across Aurora and Beta branches.
Blocks: 958697
So, I'll be attaching patches for central, aurora, and beta, for both all-locales and shipped-locales. Quite a mess, actually.

List in alphabetical order, as that's easier:

ak
lg
nso
sah
ta-LK
wo
Assignee: nobody → l10n
Central, only needs shipped-locales to be updated. The locales were already removed from the builds on central a while ago.
Attachment #8359208 - Flags: review?(jbeatty)
Aurora, both all- and shipped-locales.
Attachment #8359210 - Flags: review?(jbeatty)
... and beta, both all- and shipped-locales
Attachment #8359211 - Flags: review?(jbeatty)
Attachment #8359208 - Flags: review?(jbeatty) → review+
Attachment #8359210 - Flags: review?(jbeatty) → review+
Attachment #8359211 - Flags: review?(jbeatty) → review+
Comment on attachment 8359210 [details] [diff] [review]
bug-958703-aurora.patch

Requesting to remove the localizations in this bug from Aurora, we weren't able to resurrect them.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: Badly localized builds
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or IDL/UUID changes made by this patch: None
Attachment #8359210 - Flags: approval-mozilla-aurora?
Comment on attachment 8359211 [details] [diff] [review]
bug-958703-beta.patch

Requesting approval to remove the localizations in this bug from Beta, as much as they've been exposed.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky): 
String or IDL/UUID changes made by this patch:
Attachment #8359211 - Flags: approval-mozilla-beta?
Comment on attachment 8359210 [details] [diff] [review]
bug-958703-aurora.patch

Approving the aurora and beta patches. Also adding verifyme for QA to spot check that these locale builds do not appear
Attachment #8359210 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #8359211 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Keywords: verifyme
This patch did not land as a part of beta 6 build so we will still see these locale build exiting in tomorrows beta builds.
https://hg.mozilla.org/mozilla-central/rev/5bf95850a085
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Verified here:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-01-16-00-40-03-mozilla-aurora-l10n/
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-aurora-l10n/

There are no builds for the dropped locales after 01/14.

.../latest-mozilla-aurora-l10n/ does contain the builds from 01/12-01/13 though. Shouldn't they get removed from there?
(In reply to Ioana Budnar, QA [:ioana] from comment #14)
> .../latest-mozilla-aurora-l10n/ does contain the builds from 01/12-01/13
> though. Shouldn't they get removed from there?

They were removed for latest-mozilla-central-l10n.

No builds for the locales in comment 0 here:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central-l10n/
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2014-01-16-03-02-50-mozilla-central-l10n/
Status: RESOLVED → VERIFIED
Keywords: verifyme
Component: Build Config → General
Product: Firefox → Firefox Build System
Target Milestone: Firefox 29 → mozilla29
You need to log in before you can comment on or make changes to this bug.