(AMD Radeon) GPU drivers update causes FF window rendering to fall apart, crash

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: zxspectrum3579, Unassigned)

Tracking

({crash})

29 Branch
x86_64
Windows 7
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140110030650

Steps to reproduce:

Worked as usual on FF 29a1-64 bit for Windows (7). At the same time, installed new version of AMD Radeon Catalyst drivers.


Actual results:

After installation of drivers has successfully finished -- with, as usual, screen/resolution black flashing effect -- current tab's label on FF (with Australis skin) was gone. I have tried to click on next to current tab, and the browser immediately died.


Expected results:

Normal operation. FireFox's rendering of the main window layout should not fall apart if video driver is updated during the work of the browser. Firefox engine should re-create window anew perfectly fine as any other program, which does not get visual artefacts and crashes during update of video drivers.
(Reporter)

Comment 1

5 years ago
https://crash-stats.mozilla.com/report/index/06d88b04-7a8d-4cc1-b06b-5f0c02140110
Crash Signature: @0x7fed474135d
Hardware: x86 → x86_64
(Reporter)

Comment 2

5 years ago
To be fair, of course, I am not an expert, and maybe there is nothing what Mozilla programmers could do about this if ultimately it is AMD's or Microsoft's glitch.

But, just in case, I need graphics/layout professional to say one way or another at least on Firefox' part. How much sound, protected architecturally the engine against dynamic changes in video driver.
Try to disable the hardware acceleration in Firefox (Tools/Options/Advanced/General/Use hardware acceleration).
Also please post here your graphics section in about:support.
(Reporter)

Comment 4

5 years ago
Turning off hardware acceleration could possible help to avoid the crash, but this was a one-time event. I filed this report to let know Mozilla developers that their video/layout rendering engine is not sound against on-the-fly video driver updates.

____________________________________________________________________

Graphics
Adapter Description	AMD Radeon HD 6900 Series
Adapter Drivers	aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
Adapter RAM	2048
ClearType Parameters	Gamma: 2200 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 50
Device ID	0x6718
Direct2D Enabled	true
DirectWrite Enabled	true (6.2.9200.16571)
Driver Date	12-6-2013
Driver Version	13.251.0.0
GPU #2 Active	false
GPU Accelerated Windows	1/1 Direct3D 10
Vendor ID	0x1002
WebGL Renderer	Google Inc. -- ANGLE (AMD Radeon HD 6900 Series Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote	false
AzureCanvasBackend	direct2d
AzureContentBackend	direct2d
AzureFallbackCanvasBackend	cairo
AzureSkiaAccelerated	0
Do you still reproduce this on the latest nightly ?
Flags: needinfo?(zxspectrum3579)
(Reporter)

Comment 6

5 years ago
Since I do not install drivers very often, I had no chance to check it. Unless you can confirm that newest build had undergone changes in way how FireFox layers engine keeps in touch with Windows GUI objects descriptors/handlers -- that get destroyed during driver updates -- it makes no sense to arrange experiments about this.

Ideally, FireFox layer engine should get low level incoming event message that whole Windows' video was destroyed and re-created anew with different descriptors/handlers, so FireFox could keep up with the changes instead of "thinking" that nothing has changed, what leads to failure to process GUI, GUI events and to inevitable freeze/crash.
Flags: needinfo?(zxspectrum3579)

Comment 7

5 years ago
Should be WONTFIX, Firefox will often crash when using Firefox while updating Drivers. This is likely difficult if not impossible fix due to the way AMD updates it's drivers. It always calls for a reboot to get it working correctly, and this is because for a couple of seconds, you have no graphics drivers at all. When this happens, Firefox will often crash due to no driver being there; what I mean is that during the seconds it unloads the driver for the graphics completely, and then loads a new one. During this time, hardware acceleration is temporally absent.
(Reporter)

Comment 8

5 years ago
Thanks, I see. I wonder why it is impossible to caught the even that hardware acceleration is already available again. I have loads of software besides FireFox running, and it did not crash that way.
(In reply to Nick from comment #7)
> Should be WONTFIX, Firefox will often crash when using Firefox while
> updating Drivers. This is likely difficult if not impossible fix due to the
> way AMD updates it's drivers. It always calls for a reboot to get it working
> correctly, and this is because for a couple of seconds, you have no graphics
> drivers at all. When this happens, Firefox will often crash due to no driver
> being there; what I mean is that during the seconds it unloads the driver
> for the graphics completely, and then loads a new one. During this time,
> hardware acceleration is temporally absent.

I'm pretty sure we should handle this properly, similar to when the OS needs to reboot the GPU, after a GPU hang.
Flags: needinfo?(bas)
(In reply to Jeff Gilbert [:jgilbert PTO through Mar26] from comment #9)
> (In reply to Nick from comment #7)
> > Should be WONTFIX, Firefox will often crash when using Firefox while
> > updating Drivers. This is likely difficult if not impossible fix due to the
> > way AMD updates it's drivers. It always calls for a reboot to get it working
> > correctly, and this is because for a couple of seconds, you have no graphics
> > drivers at all. When this happens, Firefox will often crash due to no driver
> > being there; what I mean is that during the seconds it unloads the driver
> > for the graphics completely, and then loads a new one. During this time,
> > hardware acceleration is temporally absent.
> 
> I'm pretty sure we should handle this properly, similar to when the OS needs
> to reboot the GPU, after a GPU hang.

You are correct.
Flags: needinfo?(bas)

Comment 11

5 years ago
I just had this happen. Firefox crashed while updating AMD beta driers. It was right at the moment it unloaded the drivers. So yes it does happen. It is not a bad bug, and it could be fixed disabled hardware accerlation, but since I update infrequently, I just let it crash. I think it can't be fixed without some serious software awareness...
(In reply to Nick from comment #11)
> I just had this happen. Firefox crashed while updating AMD beta driers. It
> was right at the moment it unloaded the drivers. So yes it does happen. It
> is not a bad bug, and it could be fixed disabled hardware accerlation, but
> since I update infrequently, I just let it crash. I think it can't be fixed
> without some serious software awareness...

For various reasons, we have to handle this situation anyways, so we should already have mechanism. We have this mechanism for WebGL, so if we don't have it for Layers, that's really bad.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

5 years ago
Severity: normal → critical
Crash Signature: @0x7fed474135d → [@ @0x7fed474135d ]
Keywords: crash

Comment 13

5 years ago
I've encountered this multiple times. Just now on Windows 8.1 with latest Firefox Nightly (32.0a1) it didn't crashed, but it still was unusable because FF went white. Look at screenshot http://i.imgur.com/XoN3TrG.png only way was to close and open it again. It was still all functional as I could switch between tabs just couldn't see anything :D

And I must say that reboot after driver update isn't required as I haven't experienced any problems with any other applications and even Firefox after closing and opening again works perfectly fine.

Comment 14

4 years ago
Reboot is not really needed, but it is best after updating driver. The latest stable driver has stability issues and crashes often twice a day, so I had to download the beta driver again. Anyway, I now think this is a bug as firefox nightly x64 still crashes if I update the driver, so I now close it when I need to. The latest bug in the stable is that the user part of the WDDM crashes and reloads, kind of annoying but when it does firefox turns white. I've used nightly from now on and never get crashes, but radeon driver stable has stablity issues. Still, it needs to be fixed as there probably is no check for layers, because when updating drivers, firefox crashes. I haven't tested it for nightly however. I use nightly x64 because firefox uses a lot of memory when I have 100 pages open, and it uses about 3 gb, beyond when firefox x86 can handle. Sometimes 200 or so, I don't know how many. Regardless, I'm forced to as I like having a lot of pages. I do hope it gets fixed however.
(Reporter)

Comment 15

4 years ago
FireFox 37 (currently Nightly) immediately dies if AMD drivers are installed (no GUI falling apart has time to happen):

https://crash-stats.mozilla.com/report/index/be3824ec-d9b6-4be6-82ba-77b512141216
Mass resolving WFM: signature(s) hasn't(/haven't) reported in past 28 days.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.