Closed Bug 958873 Opened 6 years ago Closed 5 years ago

Use HTTPS for Bing searches

Categories

(Firefox :: Search, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 958874

People

(Reporter: briansmith, Assigned: mconnor)

References

()

Details

(Keywords: privacy)

Attachments

(1 file)

https://www.bing.com and https://bing.com are now working in a useful way. Let's switch Bing in the search box to use HTTPS like we did for Google in bug 633773.

Three things to note:

1. https://api.bing.com is not working yet, so I didn't switch search suggestions. I will file a follow-up bug for that.

2. I noticed some files have this:
       <SearchForm>http://www.bing.com/search</SearchForm>
   and other files have:
       <SearchForm>https://www.bing.com</SearchForm>

   The inconsistency seems strange.

3. The patch was tested only on desktop Firefox.

I would like to uplift this to Firefox 28 if possible. I guess we should check with Bing to see if they are cool with this, but I am not sure who should own that part.
I filed bug 958874 to enable HTTPS for the search suggestions once Bing supports that.

Note that making Bing default to HTTPS by default is not as useful as it could be without the search suggestions being HTTPS, because the search suggestion requests will leak the contents of the search done from the search box. But, it is still useful to switch to HTTPS before search suggestions are ready, because that will get the user using https://bing.com for subsequent searches that they do through the Bing web page's search box.
See Also: → 958874
Attached patch bing-https.patchSplinter Review
Attachment #8358851 - Flags: review?(gavin.sharp)
Kev worked on adding Bing in bug 603298.

Kev, could you please ask Bing to make sure they are OK with this change, and/or when they would become OK with it. See also bug 958874, which is about getting the suggestions part working over HTTPS.

Note that Bing just added HTTPS support today.
Flags: needinfo?(kev)
Keywords: privacy
Duplicate of this bug: 960076
Are we worried about any performance decrease by moving from HTTP to HTTPS? I saw bug 959835 which might be due to HTTP vs HTTPS.
Can we update metrofx as well here?
(In reply to Jim Mathies [:jimm] from comment #6)
> Can we update metrofx as well here?

The patch already does that, AFAICT. Review appreciated!
(In reply to Brian Smith (:briansmith, :bsmith; NEEDINFO? for response) from comment #7)
> (In reply to Jim Mathies [:jimm] from comment #6)
> > Can we update metrofx as well here?
> 
> The patch already does that, AFAICT. Review appreciated!

ah, awesome! Thanks! I'll take this for spin, make sure it's working.
Comment on attachment 8358851 [details] [diff] [review]
bing-https.patch

Working as expected.
Attachment #8358851 - Flags: review+
Flags: needinfo?(kev) → needinfo?(mconnor)
See Also: → 967736
Attachment #8358851 - Flags: review?(gavin.sharp)
Assignee: brian → nobody
Taking this, since I'm the right person to make the switch once they're ready to do so.
Assignee: nobody → mconnor
Flags: needinfo?(mconnor)
Target Milestone: Firefox 29 → ---
Looks like bug 958874 will be handling this
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
See Also: 958874
Duplicate of bug: 958874
You need to log in before you can comment on or make changes to this bug.