OpenH264: crash [@WelsDec::WelsMarkAsRef]

RESOLVED FIXED

Status

()

Core
WebRTC: Audio/Video
--
critical
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: posidron, Unassigned)

Tracking

(Blocks: 2 bugs, {crash, testcase})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Comment 1

5 years ago
Created attachment 8358939 [details]
callstack
(Reporter)

Updated

5 years ago
Component: Video/Audio → WebRTC: Audio/Video
(Reporter)

Updated

5 years ago
Blocks: 959432

Comment 2

5 years ago
root cause found, pull request can be seen via https://github.com/cisco/openh264/pull/146

Comment 3

5 years ago
root cause is array access violation: the array for look-up table was designed for valid data for optimization, but no error detection for invalid data.

Comment 4

5 years ago
Hi Christoph:
   fix it. Could you verify it on cisco/master branch? thanks!
(Reporter)

Comment 5

5 years ago
Fixed.

Tested with https://github.com/cisco/openh264/commit/fcd7a13816
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.