Closed Bug 959021 Opened 6 years ago Closed 6 years ago

[Media Encoder] Rename the HAS_AUDIO/HAS_VIDEO in ContainerWriter.h

Categories

(Core :: Audio/Video: Recording, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla29

People

(Reporter: rlin, Assigned: ayang)

References

(Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

The naming is bad, We should change it.
also change the naming on this comment
https://bugzilla.mozilla.org/show_bug.cgi?id=961618#c2


I think you should rename EncodedFrame::SetFrameData() to SwapFrameData(), and
call:

nsTArray<uint8_t> frameData;
frames.ElementAt(i)->SwapFrameData(&frameData);
mControl->WriteAVData(frameData);
Assignee: nobody → rlin
Attached patch add_swap_av_frame (obsolete) — Splinter Review
Attachment #8364872 - Flags: review?(cpearce)
Assignee: rlin → ayang
Hi Benjmin, 
Need your help to sync this patch to WebM muxer if got r+
Attachment #8364872 - Flags: review?(cpearce) → review+
Carry r+.

https://tbpl.mozilla.org/?tree=Try&rev=b89ca7fea3fb
Attachment #8364872 - Attachment is obsolete: true
Attachment #8367837 - Flags: review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/5d61348f2589
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Component: Video/Audio → Video/Audio: Recording
You need to log in before you can comment on or make changes to this bug.