keydown keyup keypress not triggering for firefox (26.0.1) and firefox beta(27.0)

RESOLVED DUPLICATE of bug 737658

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 737658
4 years ago
a year ago

People

(Reporter: kaskader, Unassigned)

Tracking

27 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox29 affected)

Details

(URL)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.72 Safari/537.36

Steps to reproduce:

http://jsbin.com/iGIfocaJ/19
try getting the first three input fields to trigger an event that allows you to get information about what char the user typed.
Same happens for jquery lib


Actual results:

no event is fired


Expected results:

keypress, keyup and keydown should be fired respectively.

Updated

4 years ago
I can repro in 29.

For the record, I looked over the source of the jsbin and it seems to be doing what it's supposed to meaning the events are probably being swallowed somehow.
Status: UNCONFIRMED → NEW
status-firefox29: --- → affected
Ever confirmed: true
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 737658
You need to log in before you can comment on or make changes to this bug.