Rename assertCurrentPage to assertCurrentPanel in AboutHomeComponent

RESOLVED FIXED in Firefox 29

Status

()

Firefox for Android
Awesomescreen
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: lucasr, Assigned: lucasr)

Tracking

unspecified
Firefox 29
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
Missed this one on the mass-renaming patch from bug 958185.
(Assignee)

Comment 1

5 years ago
Created attachment 8360343 [details] [diff] [review]
Rename assertCurrentPage to assertCurrentPanel (r=mcomella)
(Assignee)

Comment 2

5 years ago
Comment on attachment 8360343 [details] [diff] [review]
Rename assertCurrentPage to assertCurrentPanel (r=mcomella)

Review of attachment 8360343 [details] [diff] [review]:
-----------------------------------------------------------------

The match the latest terminology used in our about:home code. The big renaming patch is in bug 958185. I missed this one instance of 'page' in our code.
Attachment #8360343 - Flags: review?(michael.l.comella)
Comment on attachment 8360343 [details] [diff] [review]
Rename assertCurrentPage to assertCurrentPanel (r=mcomella)

Review of attachment 8360343 [details] [diff] [review]:
-----------------------------------------------------------------

r+ w/ argument rename.

::: mobile/android/base/tests/components/AboutHomeComponent.java
@@ +61,5 @@
>      private ViewPager getHomePagerView() {
>          return (ViewPager) mSolo.getView(R.id.home_pager);
>      }
>  
> +    public AboutHomeComponent assertCurrentPanel(final PanelType expectedPage) {

expectedPage => expectedPanel
Attachment #8360343 - Flags: review?(michael.l.comella) → feedback+
Actually, we're also misssing certain method calls, e.g. `swipeToPage`, and enums, e.g. `PhonePage`. Do you mind hitting these too?
Status: NEW → ASSIGNED
(Assignee)

Comment 6

5 years ago
Created attachment 8364464 [details] [diff] [review]
Rename 'page' terminology to 'panel' in AboutHomeComponent (r=mcomella)
(Assignee)

Comment 7

5 years ago
Comment on attachment 8364464 [details] [diff] [review]
Rename 'page' terminology to 'panel' in AboutHomeComponent (r=mcomella)

(In reply to Michael Comella (:mcomella) from comment #5)
> Actually, we're also misssing certain method calls, e.g. `swipeToPage`, and
> enums, e.g. `PhonePage`. Do you mind hitting these too?

Nice catch, Here's a more thorough patch.
Attachment #8364464 - Flags: review?(michael.l.comella)
(Assignee)

Updated

5 years ago
Attachment #8360343 - Attachment is obsolete: true
Comment on attachment 8364464 [details] [diff] [review]
Rename 'page' terminology to 'panel' in AboutHomeComponent (r=mcomella)

Review of attachment 8364464 [details] [diff] [review]:
-----------------------------------------------------------------

Nice.
Attachment #8364464 - Flags: review?(michael.l.comella) → review+
https://hg.mozilla.org/mozilla-central/rev/1d2fa2d09f5b
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
You need to log in before you can comment on or make changes to this bug.