[email] share image activity does not work without filenames property

RESOLVED DUPLICATE of bug 960282

Status

Firefox OS
Gaia::E-Mail
RESOLVED DUPLICATE of bug 960282
4 years ago
4 years ago

People

(Reporter: \, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 8359333 [details]
app.zip

tested on 1.3 Unagi

Using this test [0] from gaia, I was not able to attach an image.

[0] https://github.com/mozilla-b2g/gaia/blob/1d1f3156d9625981ed9d4e5322831c2b038ea70b/test_apps/uitest/js/API/shareimage.js

Updated

4 years ago
Assignee: nobody → jrburke
This fails because the email app expects a `filenames` array in the share activity, example from gallery app:

https://github.com/mozilla-b2g/gaia/blob/c6c2d55efb74e67208311d00e304c93cf1fffedb/apps/gallery/js/gallery.js#L1115

With that filenames property passed, the share works for me. So this bug should track the following:

1) Should share work with email without a filenames property? If so, I expect a loop to match the `number` property to add an l10n-appropriate name (also filenames length is same as number, and add any l10n auto generated names if filenames is shorter than number).

2) Update the test_apps/uitest shareimage.js to pass a filenames array.

3) Update wiki page to mention filenames:
https://developer.mozilla.org/en-US/docs/WebAPI/Web_Activities

The wiki page could probably also use a scrub of the fxos source to see what other apps use/depend on filenames being there.

In any case, this should not be a blocking 1.3 feature or bug as there is a workaround/apps in use in fxos, like gallery work.

Updated

4 years ago
Assignee: jrburke → nobody
Summary: share activity does not add image as attachment → [email] share image activity does not work without filenames property
Turns out Camera was not passing a filename either, so it was worse than what my initial scan found. 

The camera issue is tracked in bug 960282, and a fix was applied. Since that bug has more info and a fix, and is likely to be uplifted, so I will mark this bug as a duplicate, even though it did come before the other bug. Thanks for report, I was able to have a fix ready quicker because of it, and was able to use the app.zip as part of confirming the fix in 960282.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 960282
You need to log in before you can comment on or make changes to this bug.