don't print the contents of huge arrays

RESOLVED DUPLICATE of bug 1270179

Status

RESOLVED DUPLICATE of bug 1270179
5 years ago
4 months ago

People

(Reporter: nick, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Example, an ImageData object.  You can get such an object by calling createImageData on a CanvasRenderingContext2D instance.  By clicking on a logged object, the box of values appears on the right, then freezes up FF.  We probably should print all of the values of a huge array, or at least do so asynchronously.
Victor, don't we use paging for large arrays? Could it be that our heuristics need some more fine-tuning?
Component: Developer Tools → Developer Tools: Object Inspector
(In reply to Panos Astithas [:past] from comment #1)
> Victor, don't we use paging for large arrays? Could it be that our
> heuristics need some more fine-tuning?

Maybe we're missing something in our heuristics, definitely.

(In reply to Nick Desaulniers [:\n] from comment #0)
> Example, an ImageData object.  You can get such an object by calling
> createImageData on a CanvasRenderingContext2D instance.  By clicking on a
> logged object, the box of values appears on the right, then freezes up FF. 
> We probably should print all of the values of a huge array, or at least do
> so asynchronously.

Nick, can you please post a small test-case? Also, more importantly, what version of Firefox are you running?
29.0a1 (2014-01-14)

See attached.
Created attachment 8359862 [details]
test_case.zip
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1270179

Updated

4 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.